FORUMS: list search recent posts

Element 3D flickering issue

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Matthew Haywood
Element 3D flickering issue
on Nov 7, 2019 at 8:08:57 pm

Hi everyone,

I have an issue with flickering on imported .obj models when using Element 3D in After Effects when moving the camera (in my case, tracking forward in the Z axis).
The imported .objs are from the kitbash pack - 'Sci-Fi Floor Panels' from Vitaly Bulgarov.
Here is an animated gif (crop) of the problem:

It's most noticable on the 'grids' but is apparent throughout the scene, even on dimples on the far wall.

Here are some things I've tried already that haven't helped:
Updating software and GPU drivers.
Maxing out multisampling, supersampling, enabling 'enhanced multisampling', enabling subsample post effects, increasing FXAA smoothing.
Ray traced AO and with maxed RTAO multisampling.
Ray traced shadows with very high sampling and maxed out multisampling.
Subdividing my geometry in E3D and enabling 'optimize mesh'.
Switching from Physical Shaders to Standard Shaders.
Camera wiggle (out of desperation).
Changing layer quality in AE.

I've tried all of those in combination. I've also tried disabling things like shadows, AO, Depth of Field and Motion Blur and the problem persists with all of those either on or off.

I suspect that using alternative geometry would solve the problem but I'd prefer to use these assets if possible to save a lot of time.

I'd be grateful if anyone has any ideas,
Thanks

Matt


Return to posts index

Richard Garabedain
Re: Element 3D flickering issue
on Nov 8, 2019 at 7:49:16 pm

okay..looks like you know what your doing...you've tried a lot!...But I can think of 2 things you could try....make it bigger...or make it smaller....one of the 2 usually helps...and im talking about the actual size of the model...literally just make it bigger or smaller.....you could also try increasing the subdivision of the object in the element 3d scene set up


Return to posts index

Matthew Haywood
Re: Element 3D flickering issue
on Nov 10, 2019 at 3:08:07 am

Thanks for the tip Richard.
I have subdivided the mesh at different levels to no avail in Element 3D although I never thought to increase/decrease the object sizes! I'll try that at the next opportunity as well as disabling all other objects that may be unintentionally intersecting with other geometry and causing problems.

I also remembered that I hadn't tried changing the Tesselation options so I'll see if that helps as well (hopefully tomorrow).

Thanks,

Matt


Return to posts index


Hugo Lafis
Re: Element 3D flickering issue
on Nov 12, 2019 at 3:32:17 pm

This looks to be a moire pattern, caused by the grates / vents. This wiki article / gif demonstrates it pretty well:

https://en.wikipedia.org/wiki/File:070309-moire-a5-a5-upward-movement.gif

https://en.wikipedia.org/wiki/Moir%C3%A9_pattern


Return to posts index

Marc Keeling
Re: Element 3D flickering issue
on Nov 12, 2019 at 5:40:59 pm

Are you using a near orthographic camera? Fairly used to seeing flickering, but that seems pretty extreme.
Also, are there polys sharing the same space? ie Z-fighting. This gets worse the more orthographic the camera is.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]