FORUMS: list search recent posts

Hiding the drop shadow on the background

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Anne Green
Hiding the drop shadow on the background
on Jan 25, 2019 at 2:07:43 pm

Hi all! How are you?
I'm making an animation which will end up being a gif. I need it to have a transparent background. However, on one of the layers I applied a drop shadow effect and I don't know how to prevent this drop shadow from appearing on the background. I have attached an image to better explain myself: I would like the drop shadows of the wings to only appear on the surface on the right. Any ideas how to do this? If I do an Alpha Matte solid layer with the silhouette of the wings+right surface cut out, and track the wings to this solid, will it clip the drop shadows off?
Thanks very much in advance!


Return to posts index

Walter Soyka
Re: Hiding the drop shadow on the background
on Jan 25, 2019 at 5:31:10 pm

Two approaches I can think of:

2D:
Duplicate your Wings layer to create a shadow layer. Use the Fill and Blur effects to make it shadow-like, offset it, and parent it to the main Wings layer so it follows any movement you make. Duplicate your Surface layer to use as a matte, and parent it to the Surface layer so it too follows any movement you make. Stack your layers like this, from top to bottom: Wings, Surface Matte, Wings Shadow, Surface. Set Wings Shadow to be matted by Surface Matte's alpha.

3D:
Make these layers 3D. Set the light and the Wings layer to cast shadows, and set the Surface layer to receive shadows. (Additionally, set their "Accept Lights" properties to off if you don't want the layers shaded by the lights.) Separate them in Z-space and position them and the light to taste.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Anne Green
Re: Hiding the drop shadow on the background
on Jan 26, 2019 at 6:54:14 am

Yep, after some meddling, I arrived to your first solution : ) I tried deleting the drop shadow layer style and use a drop shadow effect too, but unfortunately that doesn't allow to set the shadow to overlay. I ended up duplicating the layer, displacing it a little, filling it with gray and blurring it and setting it to overlay before clipping it. It worked great!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]