FORUMS: list search recent posts

puppet tool: AE error: zero denominator comparing ratios

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Steve Bentley
puppet tool: AE error: zero denominator comparing ratios
on Jul 25, 2018 at 4:31:04 pm

Wow, fancy way of saying "divide by zero error". But anyway.

Been using the puppet tool heavily of late and have found a few issues. This one has me stopped in my tracks.
To be fair, I also have DUIK generating IK expressions for me but I don't think its to do with that as we're two months into this project and this error is a first.
I have 4 pins on a layer, have animated those pins (via links to Duik controllers). On other layers using the same techniques I've been able to add more pins once the animation was done to tweak the shape here and there. I can't seem to do that on this shape. In fact if I choose the layer, and then choose the puppet effect in the effects panel and then click the pin tool, I get this error as soon as the pin tool crosses into the viewport area, even before adding the new pin.
While the error is thrown and it prevents the screen from redrawing, I can move to another frame and it renders up fine. If I come back to the frame I was on it renders up fine. I can also scrub the timeline and everything is good.
Any clues?
AE2018 15.03 DUIK 15.52



Return to posts index

Michael Szalapski
Re: puppet tool: AE error: zero denominator comparing ratios
on Aug 2, 2018 at 1:13:24 am

Update AE. You are not sporting the latest bug fix update.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Steve Bentley
Re: puppet tool: AE error: zero denominator comparing ratios
on Aug 2, 2018 at 1:19:23 am

So updating AE will fix the bug with DUIK? but what do i do about all the issues with AE >15.1 - Been down that road already and surprisingly still have my hair.
The massive negative layers numbers I was getting when this issue cropped do go away once I save and restart AE. I ended up just rebuilding that character and all is well.
It does seem to be an AE issue. If I save and restart that DUIK error will go away for a while. But I still don't know why I couldn't get past the issue on that one set of art.



Return to posts index


Michael Szalapski
Re: puppet tool: AE error: zero denominator comparing ratios
on Aug 2, 2018 at 1:24:28 am

There were some weird little bugs that got fixed. I haven't had time to be as involved in the forums recently as I would like (my actual work has been getting in the way), but I seem to recall similar issues being addressed.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Steve Bentley
Re: puppet tool: AE error: zero denominator comparing ratios
on Aug 2, 2018 at 1:59:12 am

ya that darn work thing. I know the feeling.
I know Dave's company slapped a "you shall not pass" sticker on his version of AE2018. We've been pretty happy with 15.03 (albeit I've gotten way too friendly with the "purge all" command) but dipping our toe in anything newer resulted in all sorts of issues, not the least of which was the loss of QT codecs. We run all our mattes in QT animation best to save drive space (with 8K it adds up) and I missed that most of all. I know why its been phased out but I haven't found a good RLE replacement yet.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]