FORUMS: list search recent posts

DUIK issues (suddenly) and a large-numbered layer that won't delete

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Steve Bentley
DUIK issues (suddenly) and a large-numbered layer that won't delete
on Jul 20, 2018 at 9:32:47 pm
Last Edited By Steve Bentley on Jul 20, 2018 at 10:09:54 pm

I'm working with DUIK in AE 2018 V15.03 (to be fair Duik is also V15.52 but that version has worked well in AE2018 from day one).
I don't want to update DUIK yet as we are mid project on this one and DUIK controls have changed significantly since R15.

Suddenly DUIK is creating a mess of the layer geometry when BONEs are triggered on a bunch of puppet pins. The mesh folds in on itself to make a blob. This is a new phenomenon. I have reinstalled DUIK a few times now trying to solve this. I have a number of other layers that have DUIK generated bones controllers and IK on them that have been and still work fine, including one created just before this started happening.
And now after an undo (trying to return the mesh to its pre-boned state), I have a one of the DUIK created solids (labeled as one of the pins and that isn't a guide layer) with a huge layer number on it: -2147483647, and its negative! I cannot delete this layer. If I try, I get an error: Strange situation (0/1).
The first time this happened before I tried reinstalling, the script debugger opened up with a line of DUIK code in red. But even if it had been a corrupt script a reinstall should wipe that clean. I've also redownloaded the installer in case my exe is corrupt (DUIK had an installer for R15 and not just an unzip).

A few other details:
I have had DUIK 16 installed but the rigging pipeline we were using wasn't compatible with R16 so we removed the DUIK scripts and reinstalled R15.52. Is there a R16 prefs somewhere other than the scripts folder that also needs removal?

When I hit bones on layer 2 and the mesh collapses, it seems to want to "become" the shape of layer1, the one that has working bones linked to it. So much so that when I add a controller to layer 2, I get an expression error because layer 2's new controller ( the failed DUIK bones layer) is expressionally linked to one of layer 1's bones (a working boned layer), and not the bone on layer 2 it should be.

Thoughts?

I realized this mesh collapsing behaviour is what would happen if you didn't rename other bones and controllers from their default names. This is not the case here. All have unique names.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]