For a LARGE number of masks (around 70). The expression is working great, but after pasting the expression on the next mask (i.e. mask 20) I have to go in and manually change the name of the mask from "Mask 19" to "Mask 20".
Wondering if there's a way to have it reference itself instead of the name of a mask? Something like "thisMask"?
New territory for me, but possibly like this. The first line returns the name of the parent of the property, which should be the name of the mask. The second line returns the mask with the same name from either this layer or the "FakeSolid" layer depending on whether the mask opacity is zero or not.
p = thisProperty.propertyGroup(1).name;
if(mask(p).maskOpacity==0)thisComp.layer("FakeSolid").mask(p).maskPath else value