FORUMS: list search recent posts

Getting "Zero denominator in ratio multiply. ( 17 :: 17 )" error when working with frame-by-frame photo animation

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Xavier Bonet
Getting "Zero denominator in ratio multiply. ( 17 :: 17 )" error when working with frame-by-frame photo animation
on Dec 14, 2017 at 7:51:53 pm

I'm suddenly having a very aggravating problem in AE CC 2017. Not least because I'm already mid-way into a project and now I have no time to go back and change the way I planned to do it... Let me explain:

I'm working on a frame-by-frame animation consisting of a couple hundred photos taken with my Nikon D610. I've passed them through Lightroom and have them just as I need them, only need to put them together. I've exported them as JPGs. The pixel size of these JPGs is 4016x6016. Because they're vertical, I needed to put together a bigger horizontal background (because obviously in the end I want to be able to export a 16:9, HD vídeo — i.e., the final pixel size will be 1960x1080) that will act as a static background upon which the part that is being animated frame-by-frame will go. This background consists of only one image, 10696x6016 pixels in size. So the idea is to animate everything and then be able to "move around" the whole composition (consisting of the background and the animates images) as if the camera were zooming in and out, and also "breathing".

My compositions have a fps rate of 24, as I do also have some vídeo files I'll add on top of some parts, and these were recorded at 24fps. Because the files are image files, and I'm able to import them as sequences, AE imports them to whatever fps I want. In this case, all my comps and sequences are 24fps.

So up to this point, everything would be OK, as, except for the rather big size of the material, there's nothing crazy going on. Nevertheless, I'm crashing into *several* problems! The first annoying error, which I'm constantly getting: "After Effects error: zero denominator in ratio multiply. ( 17 :: 17 )". Now, I've already searched this error online and the only "solution" I was able to find was to go to "Interpret Footage" for the imported sequences, and check "Preserve RGB". Now, this worked at first, as I stopped getting this error. But now I'm getting it again... and there's nothing I can do: as I've already checked "Preserve RGB". Moreover, I'm finding that some sequences, when placed into a comp, end before they should. That is, let's imagine one sequence has 10 images in it. When I place it into a comp it plays up to image 6, and then it's as if there weren't anything else in that sequence, it just becomes transparent. In fact, you can see frame 6 doesn't even last an entire frame, but ends at mid-frame... as if the fps of that sequence were different than that of the comp. However, as I've stated, this is not the case.

Then, another annoying error, which forces me to save the project and quit as bes I can, because it doesn't go away once it appears, is: "After Effects error : unbalanced unlock. ( 7 :: 40 )".

I'm wondering what is going on? It's as if AE just doesn't want to work with this project. I'm starting to think that maybe I should try to cut my loses and go back to CC 2015, to see if I can work without these errors.

I've tried purging all cache and memory from AE, and I've also tried manually erasing my MBPro's cache and rebooting... All this to no avail!

Thank you so much in advance for any help you can give me!


Return to posts index

Michael Szalapski
Re: Getting "Zero denominator in ratio multiply. ( 17 :: 17 )" error when working with frame-by-frame photo animation
on Dec 15, 2017 at 2:51:18 pm

You are using some...very large images. I would highly recommend sizing them down as small as you can in Photoshop. Unless you're getting very close to the image in AE, you can size it way down. That would help a lot.

As to the issues you're experiencing, I would not recommend CC 2015 (or CC 2015.3) they were both earlier, buggier versions of the new architecture.
I would suggest either installing CC 2014 or (and this is what I would try first) installing the latest version (remember to uncheck the box that removes old versions under the "Advanced Options" when you go to "update" to the new AE). For me, CC 2018 (or just "CC" as they're apparently trying to call it) has been the most stable version of AE in a few years.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Xavier Bonet
Re: Getting "Zero denominator in ratio multiply. ( 17 :: 17 )" error when working with frame-by-frame photo animation
on Dec 19, 2017 at 11:52:20 am

Thanks a lot for the reply!

Unfortunately, I do need to zoom the image way in in AE, that's why I need such big images. The frame-by-frame animation is then given the effect of a camera zooming in and out depending on what needs to be focused on the scene.

Great recommendation about installing the latest one. When going up from 2015 to 2017 I felt like I hit a brick wall! It's SO buggy. So I was really reticent to go for the newer version. But if you say you've been using it and it's less buggy, then I'm game!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]