FORUMS: list search recent posts

Layers and elements unexplainedly disappearing in 3D worlds

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Daniel Grbac
Layers and elements unexplainedly disappearing in 3D worlds
on Jul 6, 2017 at 4:28:14 am

I just dont get what I am doing wrong... at all

As you can see via the videos - I have created a scene where a guy is looking at his IPad. The animation that happens on the iPad screen is a separate composition and is then imported into the main composition. This is to allow me to easily change what appears on the Ipad without too much fuss

In this video - the animation on the screens works PERFECTLY!






However, in this video:





where I have changed the display on the screen, the main composition has decided to just do whatever it wants. I mean I dont get this at all - I have layers inside a separate composition going in front of layers in the main composition (where the "screen" jumps in front of the thumb). And it seems the only time that AE wants to act properly is when there is movement (on everything except the image on the screen).

Everything thats wrong with it:
- when the pop-up appears at about the 10 frame mark, the image behind disappears - yet on the original composition its still there). I've even moved the pop up a few points in the z-axis in front of the screen image thinking that maybe it had a Z-axis clash, that didnt fix it
- the pop up flickers and disappears for no reason, and when it does that usually the screen image appears
- the thumb layer disappears
- at one stage the whole screen disappears and all you can see is the ipad and the pop up

I have tried pre-comping the layer, that does NOTHING at all. The only think left I can think of is to create a video of the screen and then import the AVI onto the main composition, but considering the luck I am having with AE right now it will probably find a way to make things disappear too

I'm getting fed up with coming up with work-arounds. Nothing is working logically

Before you ask
- using AE CC 2017
- yes, all layers (ALL LAYERS IN ALL COMPOSITIONS) are set to 3D. Remember, it worked OK the first time, just not the second
- the 3D world is set up so that the layers display in the right order

The only thing i can think of is its a camera fault. When I preview this via the FRONT view, rather than ACTIVE CAMERA or CAMERA 1, its fine (but then I dont get the correct composition or the the wiggle movement I want

Any useful help would be much appreciated. Thanks


Return to posts index

Tudor "Ted" Jelescu
Re: Layers and elements unexplainedly disappearing in 3D worlds
on Jul 6, 2017 at 11:33:51 am

Things to check for:

1- Layers are stacked in the same order they are in 3d space ( I know it should not matter but it does)
2- there should be a few units difference in z space on layers (make sure that plans that do not intersect are perfectly parallel)
3- there are no 2d layers (including Adjustment layers) in between 3d layers

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

Walter Soyka
Re: Layers and elements unexplainedly disappearing in 3D worlds
on Jul 6, 2017 at 1:19:00 pm

There are a number of things that will break 3D intersections in a Classic 3D comp:

  • A 2D layer
  • An adjustment layer
  • A 3D layer with a layer style applied
  • A 3D precomposition layer to which an effect, closed mask (with mask mode other than None), or track matte has been applied
  • A 3D precomposition layer without collapsed transformations


See here for more:
https://helpx.adobe.com/after-effects/using/3d-layers.html#3d_layer_interac...

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index


Daniel Grbac
Re: Layers and elements unexplainedly disappearing in 3D worlds
on Jul 7, 2017 at 2:21:07 am

Thanks Walter - I am thinking its the third dot point as I dont pre-comp anything, so there cant be an issue there

I need to figure out what kind of layer style I've applied now (I have no idea what it could be, so Ill need to go over them all with a fine tooth comb)

I ended up exporting the screen composition as a video with alpha, and then replacing that composition layer in the main composition with the video file. Luckily no resolution quality issues!


Return to posts index

Walter Soyka
Re: Layers and elements unexplainedly disappearing in 3D worlds
on Jul 7, 2017 at 12:19:55 pm

[Daniel Grbac] "where I have changed the display on the screen, the main composition has decided to just do whatever it wants. I mean I dont get this at all - I have layers inside a separate composition going in front of layers in the main composition (where the "screen" jumps in front of the thumb). And it seems the only time that AE wants to act properly is when there is movement (on everything except the image on the screen)."

Do you have the "collapse transformations" switch enabled or disabled for the precomp's 3D layer?

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Daniel Grbac
Re: Layers and elements unexplainedly disappearing in 3D worlds
on Jul 10, 2017 at 12:28:43 am

I havent pre-comp'd any of the layers

Sounds like I should do that first?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]