FORUMS: list search recent posts

Using a layer as an Element 3D material for template.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Hubert Blajer
Using a layer as an Element 3D material for template.
on May 2, 2017 at 5:46:09 pm

Hello everyone
So here is the thing. I am creating a template for mobile app promo with a phone model in element 3d, however i want this template to not require Element 3D, basically i want to use pre-rendered footage of the phone, but there is one problem. To apply screen footage to the phone I need to change material in Element 3D so if someone would be using it without E3d he couldn't do it. The only thing that comes to my mind is placing the screen footage on top of the screen but then i found that it is impossible to use camera without messing up whole footage and also the reflections aren't there obviously.

I would be very greatfull if someone could give me any advice on that. ☺

Hubert


Return to posts index

Cassius Marques
Re: Using a layer as an Element 3D material for template.
on May 3, 2017 at 5:04:20 pm

[Hubert Blajer] "The only thing that comes to my mind is placing the screen footage on top of the screen but then i found that it is impossible to use camera without messing up whole footage"

What do you mean to "use camera"? If you are rendering it to be a footage you'll end up with no camera at all!

[Hubert Blajer] "and also the reflections aren't there obviously."

Well obviously you'll have to render them out too and precompose them on top, you know, like one would do with a footage. (render with a black screen and use it in screen blend mode on top having your screen comp as an alpha mate).

Cassius Marques
http://www.zapfilmes.com


Return to posts index

Hubert Blajer
Re: Using a layer as an Element 3D material for template.
on May 4, 2017 at 4:05:35 pm

[Cassius Marques] "What do you mean to "use camera"? If you are rendering it to be a footage you'll end up with no camera at all!"

Yes, i know that, it is not whhat I meant, sorry, maybe I didn't describe it properly. Using the camera BEFORE pre-rendering footage makes it move diffrently, which makes "screen" moving off of the phone. Even tho when I for example rotate both individually(without using camera, just by changing rotation value on both of em) everything is ok. Only camera movoments create problems. But thats not that bad since i can rotate/move them invidually.


Thank you a lot for the second tip tho, for some reason I didn't think of it. Helped me a lot.

Cheers
Hubert


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]