FORUMS: list search recent posts

Problem with collapse layers + precomps

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael Litwak
Problem with collapse layers + precomps
on May 2, 2017 at 4:38:21 pm

hello,

currently going crazy because I have two comps that seem to be identical in all ways but for some reason the collapse layers is working in one and not in the other. I'm trying to add engines (made up of a Video Copilot flare + Video Copilot Saber solid) to the back of miniature spaceships which i've tracked and put inside a precomp. as you can see, i want the red engine to ADD into the background but its not showing up as ADD (look at disembodied engine next to it as an example of the way it should be.




and here is the other comp where its WORKING with an example of the red engine next to it making me think that it's not something to do with the ENGINE PRECOMP or the SHIP PRECOMP



if you look next to the collapse transformations thing, the blend mode on the working one has a dash through it, that's the only difference I can see as to why it's not working but I have no idea why!!

and here are pics of the precomps themselves





please help, I will be most grateful!

-Michael


Return to posts index

Walter Soyka
Re: Problem with collapse layers + precomps
on May 3, 2017 at 12:56:00 pm

You have a Keylight effect applied to your Comp 04_MINI SHIP Profile WS (REUSE) layer. You've got it disabled right now, but you should delete it entirely. Here's why:

When a closed mask (with mask mode other than None), a layer style, or an effect is applied to a nested composition with collapsed transformations, the layers in the nested composition are first rendered on their own, then masks and effects are applied, and then the result is composited into the main composition. This rendering order means that the blending modes of the nested layers are not applied to any underlying layers in the main composition, and that 3D layers above and below the collapsed layer cannot intersect or cast shadows on each other.

( from https://helpx.adobe.com/after-effects/using/precomposing-nesting-pre-render... )

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Michael Litwak
Re: Problem with collapse layers + precomps
on May 3, 2017 at 2:02:34 pm

heyo,

you are correct, the disabled keylight was affecting it, but i'm confused as to why a disabled effect still alters things?

the mask was also set to "none" so it was quite infuriating.

anyways thanks for your help!

-Michael


Return to posts index


Walter Soyka
Re: Problem with collapse layers + precomps
on May 3, 2017 at 2:15:19 pm

[Michael Litwak] "you are correct, the disabled keylight was affecting it, but i'm confused as to why a disabled effect still alters things?"

Good question. I guess Ae just looks to see if effects are applied, not visible, in order to determine which render pipeline to use. You could file a bug report/feature request about this behavior.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]