FORUMS: list search recent posts

deinterlace 50i to 25p with smooth motion

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Zsolt Koppányi
deinterlace 50i to 25p with smooth motion
on Nov 20, 2016 at 4:45:05 pm

Hello,

I sent this post to Premiere Pro forum but I use both programs, and could an AE expert here who knows the answer.

My original footage (.mts) setting is 1920x1080 50i (this cam can't record progressive frames)
and I'd like to export them as 25p from the timeline of AE or PPro 2015.

In the beginning, I made a composition matching my footage settings and changed Field Order to Progressive in AME. However the quality of the output (H.264) was worse than my original AVCHD source watching on both WinMediaPlayer and VLC. Artifacts (combs) doesn't occured but "stuttering" (frame skipping) appeared in the movements.

After a lot of tests, I found a solution: rendering with double frame rate

In PPro: my sequence match the original footage settings (50i) and render to 50p.
In AE: I also have to double the Comp's frame rate (50fps) and render to 50p

The result is perfect, movements got smooth like the original.
I'm aware it's not an elegant solution, but works. However I'm looking for a method how to convert 50i to only 25p without jerkyness?
I applied Fieldskit Deinterlace tryout on the footage (interpreted to progressive) with a lot of adjustments but after rendering to 25p I didn't experienced any improvement in the stuttering. Is there anyone who can achieve perfect results using such plug-ins?

Every time I use "Mercury Playback Engine Software Only", because OpenCL often interrupt rendering.

Thank you
Zsolt


Return to posts index

Dave LaRonde
Re: deinterlace 50i to 25p with smooth motion
on Nov 20, 2016 at 11:26:26 pm
Last Edited By Dave LaRonde on Nov 21, 2016 at 12:50:47 am

Sorry, but you must sacrifice smoothness of motion to get progressive frames. 50 -- whether it is fields or frames -- is 50 slices of time each second. You get 50 chances to capture the motion.
But when you go to 25p, you only have 25 slices of time each second. You have half the number of chances to capture the motion. The result is less-smooth motion.

It is a fact of life you must accept. You can't change it. It would be like discovering a way to be in two places ar once.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Zsolt Koppányi
Re: deinterlace 50i to 25p with smooth motion
on Nov 21, 2016 at 6:40:50 pm

Thanks Dave,

You clarify this for me with the slices and accept it. So if I want to import 25p footages or 25fps AE comps into my 50i timeline, will the exported progressive files be OK after rendering to 50p too?

Zs


Return to posts index


Chris Wright
Re: deinterlace 50i to 25p with smooth motion
on Nov 22, 2016 at 5:01:24 am

if you put a 25p into 50i Ae timeline, you'll get duplicate frames to fill up the missing spots unless you turn on frame or pixel blending for that layer.

there's also a way to turn 25p into 50i either with fieldskit re-interlacer or AE's optical flow rendered out and given fake fields. it's pretty crazy but it works.


Return to posts index

Zsolt Koppányi
Re: deinterlace 50i to 25p with smooth motion
on Nov 22, 2016 at 6:55:48 pm

Thanks Chris,
I find that in AE comp settings doesn't have an option to adjust upperfield/lowerfield timeline. I can set frame rate only. However PPro allows it in sequence settings.


Return to posts index

Chris Wright
Re: deinterlace 50i to 25p with smooth motion
on Nov 22, 2016 at 8:14:54 pm

in AE, right click footage, interpret to change field.


Return to posts index


Zsolt Koppányi
Re: deinterlace 50i to 25p with smooth motion
on Nov 22, 2016 at 8:48:38 pm

Thank you for your help!

Zs


Return to posts index

Walter Soyka
Re: deinterlace 50i to 25p with smooth motion
on Nov 22, 2016 at 8:52:23 pm

[Zsolt Koppányi] "I find that in AE comp settings doesn't have an option to adjust upperfield/lowerfield timeline. I can set frame rate only. However PPro allows it in sequence settings."

In After Effects, fields are enabled in the render queue, not in the comp settings.

Add your comp to the render queue, then open up its Render Settings (by clicking on the name of the Render Settings template applied, ususally "Best Settings" by default). In the Time Sampling section, change Field Render from Off to Upper Field First or Lower Field First to render interlaced.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]