FORUMS: list search recent posts

After Effects and Element 3D lighting problems

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Andrew Fau
After Effects and Element 3D lighting problems
on Aug 18, 2016 at 1:17:25 pm

Hey everyone. I have an issue whereby I have an element 3D layer in a project that is essentially ignored by any lights that I add to the project. I say "essentially" because for whatever reason, if I use an ambient light, it will illuminate the E3D layer. The other three types, however, will not. I've been trying to figure this out for days to no avail. I've scoured the web for answers and tried every suggestion. Again, no luck. The only way that I can get all of the lights to react to the E3D layer is to turn on 3D for the layer itself.

I don't remember every single thing that I've tried but a couple that stand out are:

1) I've checked to make sure that fast previews are turned off
2) E3D layer is set to accept comp lights

I'm working on an older Mac without a discrete GPU (wondering if this might be the problem). I'm using AE CC 2015.3 V. 13.8.1. The version of E3D is 2.2.2.

If there's more information that I can provide which might help someone to diagnose the issue, I would be happy to do so. I'm really hoping this is just a stupid setting or something relatively simple that I need to fix.


Return to posts index

Kalle Kannisto
Re: After Effects and Element 3D lighting problems
on Aug 19, 2016 at 6:41:50 am

It's bound to be a GPU issue, but you could check if turning up the lighting influence setting under physical environment settings does anything. The default is 25%, wherein 75% of the lighting comes from the environment map.

Kalleheikki Kannisto
Senior Graphic Designer


Return to posts index

Andrew Fau
Re: After Effects and Element 3D lighting problems
on Aug 19, 2016 at 2:38:07 pm

Thank you for the response. I actually did try to change that initially–it was one of the many things I did. In the interest of being thorough, I just tried it again to no avail. The only thing that changed was the brightness of the E3D object, e.g., it became darker.


Return to posts index


Walter Soyka
Re: After Effects and Element 3D lighting problems
on Aug 19, 2016 at 6:22:03 pm

[Andrew Fau] "The only thing that changed was the brightness of the E3D object, e.g., it became darker."

This sounds like the light is present in the scene, but is not positioned correctly to affect the object the way you want. Can you confirm that any point lights are close to the Element 3D object, or that spotlights are pointed at it?

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Andrew Fau
Re: After Effects and Element 3D lighting problems
on Aug 19, 2016 at 8:22:07 pm

Yep, the one light that I have in there for testing purposes appears to be in the correct position. I don't know what is going on.


Return to posts index

Walter Soyka
Re: After Effects and Element 3D lighting problems
on Aug 19, 2016 at 8:26:11 pm

It could very well be a limitation of the OpenGL implementation on your integrated graphics card; Element 3D does not formally support these. If you want to post an AEP, I'll try to look at it for you.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index


Andrew Fau
Re: After Effects and Element 3D lighting problems
on Aug 19, 2016 at 8:29:17 pm

Sure, I can do that. I appreciate the offer. So I'm still getting used to AE. Years of experience with all other adobe apps just not this one. Is there a way I can package all of the fonts and imagery from with AE?


Return to posts index

Andrew Fau
Re: After Effects and Element 3D lighting problems
on Aug 19, 2016 at 8:35:50 pm

Here it is with all supporting files.

10441_ssintro.zip


Return to posts index

Walter Soyka
Re: After Effects and Element 3D lighting problems
on Aug 23, 2016 at 9:58:59 am

The issue probably lies with your unsupported GPU. I loaded your project and this seems to work fine here.

Here's the light off:


And here's the light on:


Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]