FORUMS: list search recent posts

Masks stop working after adding effects.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jakub Zawadzki
Masks stop working after adding effects.
on Feb 13, 2012 at 4:35:21 pm

Hi,

I've put a mask on a smoke video. Video is over some jpg. After adding an effect (switch channels alpha->red) my mask stops working. Video is not cropped as i'd like it to be anymore. What am I doing wrong?


Return to posts index


John Cuevas
Re: Masks stop working after adding effects.
on Feb 13, 2012 at 4:47:27 pm

The mask defines the alpha channel of the layer and it's the first thing that AE looks at. After you told it, use this alpha channel, you applied an effect that says use this alpha channel. AE's order of operations is Masks -> Effects -> Transformations.

If you want to use both(shift channels & mask), apply the effect to your video and precompose your layer, "shift + cntl + c". Now mask the precomposed layer.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

Jakub Zawadzki
Re: Masks stop working after adding effects.
on Feb 13, 2012 at 5:06:25 pm

I thought so. Already figured out the pre-comp ;) It's a pity you cannot change the order of operations :(
Thanks for an answer.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]