FORUMS: list search recent posts

CS6 Casting Shadows issue

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Josh Hnosko
CS6 Casting Shadows issue
on Oct 1, 2012 at 8:10:24 am

I have a project where I am taking 2D images and arranging them in 3D space then lighting them so they cast shadows on one another. I have the light setup to cast shadows and the objects in my timeline that I want to have shadows on them are accepting both shadows and light.

My problem that I am experiencing is that, while working in Fast Draft mode the shadows are visible but when I render or turn Fast Previews off, the shadows disappear. They aren't even just softened or slightly off, they just don't exist.

I've tried moving my light around, turning the shadow darkness up, messing with layer positioning and nothing will get the shadows to show up when Fast Preview is turned off. I've tried searching for it online and all I seem to get is tutorials or stuff about raytracing.

I'd like to get this figured out soon so I can move on through the project. Is this a bug or am I overlooking something here?

Timeline Settings:
HDV 1080 29.97 Preset (client is working in HDV)


Return to posts index

Josh Hnosko
Re: CS6 Casting Shadows issue
on Oct 1, 2012 at 8:21:22 am

Also note that I'm not working with a bunch of pre-comps. These are PSD's that have been layered in the main comp and then lit. I'm struggling to understand why the shadows are there for Fast Draft and not for Final Quality.


Return to posts index


Roland R. Kahlenberg
Re: CS6 Casting Shadows issue
on Oct 1, 2012 at 8:31:16 am

Do you have any PS Layer effects on your layers? These will break 3D layer interactions. If you do and you really really need them, then place each layer into their own preComp in AE and nest them into a 'final comp' - ensure that you do not Continuously Rasterize the nested comps/layers.

Having said that, I have no idea why Fast Draft shows the shadows while Final Quality doesn't.

HTH
RoRK

Intensive AE & Mocha Training in Singapore and Malaysia
Adobe ACE/ACI (version 7) & Imagineer Systems Inc Approved Mocha Trainer


Return to posts index


Josh Hnosko
Re: CS6 Casting Shadows issue
on Oct 1, 2012 at 7:45:11 pm

I tried pre-comping them and nesting them back in the final sequence but the shadows are still disappearing when I go to final quality from fast draft.

This is how it looks in Fast Draft


This is how it looks with Fast Preview off (Final Quality)


Return to posts index

Josh Hnosko
Re: CS6 Casting Shadows issue
on Oct 1, 2012 at 8:47:25 pm

I have found out the switching the render mode from Classic3D to Raytraced3D makes the shadows show up on Final Quality but it takes forever to render. Did they get rid of the ability to have shadows pass through alpha layers in CS6's Classic3D render mode? Am I stuck with rendering with raytracing? I don't have 10 hours to spend to render out an approval file for a 12 second clip. Is there some setting that is buried in menus that will allow light/shadows to pass through alpha channels? Raytracing is new to CS6 but I've always been able to have shadows pass through before when I used CS5.

I'm confused and frustrated right now so any help would be much appreciated.


Return to posts index

Josh Hnosko
Re: CS6 Casting Shadows issue
on Oct 1, 2012 at 9:14:14 pm

Another update. I just borrowed a friends CS5 system and quickly rebuilt part of my sequence as a test to see if the issue popped up in CS5 and it does not. I set the Fast Preview to off and the shadows remain and it renders out with shadows. I don't have CS5 on my system and Advanced3D (CS5) and Classic3D (CS6) renderer should be pretty much the same right?


Return to posts index


Josh Hnosko
Re: CS6 Casting Shadows issue
on Oct 2, 2012 at 1:25:42 am

Ok, final update and solution. Turns out there were layer styles. I had removed them from the PSD and reloaded the images but the layers, and thus the pre-comps I converted them to later, still had them. As soon as I deleted them it was perfect. Thanks for the help Roland, it did the trick but I had to do some digging through my project to figure out that was my issue.


Return to posts index

Roland R. Kahlenberg
Re: CS6 Casting Shadows issue
on Oct 2, 2012 at 3:43:22 am

I'm glad things have worked out for you Josh. My thoughts now are that you should send in a Bug Report to the AE Team on the discrepancy with the Fast Draft render. You can do everyone a favor by sending an abbreviated AEP (2-3 layers) and the two snapshots you posted here at the following URL - https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform.

Cheers
Roland

Intensive AE & Mocha Training in Singapore and Malaysia
Adobe ACE/ACI (version 7) & Imagineer Systems Inc Approved Mocha Trainer


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]