FORUMS: list search recent posts

Mocha tracking off in AE ! Can someone tell me what im doing wrong please

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Matt Stoltz
Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 18, 2011 at 10:26:20 pm

http://c777870.r70.cf2.rackcdn.com/trackweb.mov


Heres the example --You can see on the first frame its aligned- I cant figure out why my track and mask are not at the same speed - the track is right on in Mocha but when I past the Mocha data in AE --its off.
I have checked all the timecode and frame rates and ect. Cant figure it out.

anyone have any ideas

Matt


Return to posts index

Martin Brennand
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 18, 2011 at 11:49:27 pm

Are you using a corner pin or a transform track?

If you are using corner pin, is the insert layer the same size as the composition? If not you will have to adjust it with a manual corner pin first, precompose it and then use Align Surface in mocha before you export.

Martin Brennand | Product Specialist | Imagineer Systems


Return to posts index

Matt Stoltz
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 19, 2011 at 3:30:40 am

Hey Martin

I used and did exactly everything you said prior to posting this thread-I actually took the video into AE first and exported a still so I could change the the text on the ends of the boxes.

I actually just got it to work--Heres what I found out was wrong. I exported the tracking data as corner in (with blur support) and in AE I have the original video on one layer and my still with the color ends on the a layer right above the video layer. i pasted the track data to the still and that worked fine.

Then I went back to Mocha and exported the shape data and pasted that on the still--That worked fine-

HERES where I found the problem- I posted the video you saw with just one box having color on the end but in reality I need to put a color on every end of each box -So I originally had 2 mask that I exported from Mocha and pasted in AE - NOW when I pasted both mask -1 mask came in with blend mode to to add and the other set to multiply-from more messing around I changed that one mask from multiply blend mode to add and it worked completely fine and result was perfect.

why did the mask come in like that ?

thanks for your help on this

matt


Return to posts index


Matt Stoltz
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 19, 2011 at 3:38:58 am

Hey Martin

Forget what I said before - its sort of working- my whole still plate is moving and not cutting out the mask --I didnt notice before. I think I may just upload all my files so you can take a look at it

Matt


Return to posts index

Matt Stoltz
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 19, 2011 at 3:53:45 am

Hey Martin

here is the link to all my files -Mocha AE 2.3.0 and AE CS5.5 OSX
hope you can help me out and figure out what Im doing wrong-I need to figure this out because this is for a really big client

Matt

http://c777870.r70.cf2.rackcdn.com/mochatest.zip


Return to posts index

Martin Brennand
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 19, 2011 at 5:44:27 am

Thanks Matt, i'll take a look now.

Martin Brennand | Product Specialist | Imagineer Systems


Return to posts index


Martin Brennand
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 19, 2011 at 6:04:06 am

Ok, I think I can see what is going on here.
When you paste an animated mask onto the existing tracked layer, you're actually getting two tracked items (the layer and the mask), so the animate shape is going to shift at twice the rate of the tracked layer. For this kind of thing you can do one of the following:

1. Just use the tracking data on the colour layer and then draw a static mask. Since the tracking is moving the inserts you don't need to animate the shape.
2. Apply the masking and the tracking to separate layers and use the masking layer as a track matte. This way if you've done manual changes to your roto in mocha you've got the flexibility of being able to use both the shape and track data.

The add/multiply thing is for handling multiple roto shapes for heavy roto. This is a fallback from the shape effect (as opposed to using the AE masks). If there is a preferred workflow you'd like to see, let us know

I hope this helps!

Martin Brennand | Product Specialist | Imagineer Systems


Return to posts index

Matt Stoltz
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 19, 2011 at 2:15:52 pm

Hey Martin

thanks for looking at this for me-

OK I did your first suggestion --and applied the tracking to the color layer and drew a mask on the color layer in AE and it worked- My concern with this yes the track is moving the color layer but since the mask is not being animated -What if your shape in Mocha shifts from the first frame to the last frame where in Mocha at certain points you had to adjust your mask shape.

I think I like suggestion 2 better- where the shape layer is animated from Mocha-But I tried what you said but Im still not getting it right--I have my video layer on bottom, one color layer above that with the tracking data on it and then another color above that with the shape data on it. On the top layer that has the shape data-I clicked the track matte button but I get the same results as before.

Sorry to be a pain-
Any chance you could show me #2 example and send me the AE file and I will just relink media as needed --I think I would understand it much better

Thanks for your help

Matt


Return to posts index

Martin Brennand
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 20, 2011 at 6:32:28 am

3108_mbtest.aep.zip

Try this. The steps I took were:

1. Drag the footage into a new comp
2. Drag the insert on top
3. In mocha Select "rough track" and hit Align Surface.
3. Export the track as a CP with motion blur
4. Paste the track data onto the insert in AE
5. Go back to mocha, export all visible shapes
6. Create a new solid and paste the mocha mask data
7. On the footage layer, set track matte to the alpha of the above layer.

Martin Brennand | Product Specialist | Imagineer Systems


Return to posts index


Matt Stoltz
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 20, 2011 at 4:40:19 pm

Hey Martin

http://c777870.r70.cf2.rackcdn.com/test.aep.zip

Thanks -I see what you did now. So what you did that mask will shift and expand as the same as the tracked shape layer in Mocha??

Also Im sending you what I did--I did your first step you suggested and it seems to work. But not sure if it works the same as what you did. You can see I just took the track of each box end I tracked --CP (with blur) data from Mocha and pasted it to the 2 insert layers and then just drew my own mask around them (if you toggle on the mask visibility switch) -So basically for every box end I could "technically" do it the way I did it as well?? Correct?? and everything will shift and move correctly?

You can see Im a little new to the whole tracking and Mocha thing but Im trying to get it :)

thanks for your help -If you just let me know if my way will work fine too --Thats cool and I will definitely keep your test you sent me for future reference.

Thanks

Matt


Return to posts index

Martin Brennand
Re: Mocha tracking off in AE ! Can someone tell me what im doing wrong please
on Oct 24, 2011 at 1:42:07 am

Yes, you could just as easily do a corner pin for every box and link it the same way, rather than doing a mask. Of course the mask gives you more flexibility in terms of falloff, feathering etc, but there is never one way to do it. You've got options.

Martin Brennand | Product Specialist | Imagineer Systems


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]