FORUMS: list search recent posts

SDX900 Battery Issues and Questions

COW Forums : Panasonic Cameras

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Zach Rutledge
SDX900 Battery Issues and Questions
on Jul 28, 2009 at 12:18:58 pm

I have a multi-part question about my SDX900.

First I seem to be draining power on my Dionics a lot faster than normal. Could there be something pulling power from those batteries that I am not aware of?

Second one of my three Dionics is not working. Just seeing flashing time remaining on the LED screen. Is it busted or is there a way to fix it?

My biggest issue is popping up when I want to use my Frezzi light. My batteries can barely last a few minutes with that light on. Is there a good battery to run that light for extend periods of time?

Thanks for all the help!



Return to posts index

Ernie Santella
Re: SDX900 Battery Issues and Questions
on Jul 28, 2009 at 5:08:55 pm

How old are the Batteries? They have a limited lifespan. After a while, all batteries stop holding charge. You might be at the point.

Ernie Santella
Santella Productions Inc.
http://www.santellaproductions.com


Return to posts index

Zach Rutledge
Re: SDX900 Battery Issues and Questions
on Jul 28, 2009 at 5:12:48 pm

Two are 3 years old and one is 2 years old. The drain just seem to start about 3 weeks ago. One shoot it was fine and normal, the next shoot I started losing power very very quickly.

Now one of the 3 year old batteries is not working at all. The LED screen just flashes a hour number.



Return to posts index


Ernie Santella
Re: SDX900 Battery Issues and Questions
on Jul 28, 2009 at 5:24:24 pm

3 years under normal use sounds like that could be your issue. What makes me think that is your camera light. Just running that brings the battery down fast. That has nothing to do with the camera electronics.

Ernie Santella
Santella Productions Inc.
http://www.santellaproductions.com


Return to posts index

Zach Rutledge
Re: SDX900 Battery Issues and Questions
on Jul 28, 2009 at 5:29:50 pm

I have heard of the life slowly diminishing over time but to see a huge change one to the other is a little extreme and then I have the issue of the one battery that is completely busted. It is almost as if the camera had a power surge because I have also blown my ME66. I have a feeling it was the gold mount because during my last shoot my light just stopped working. After replacing the gold mount the light now works. Could the gold mount have caused a surge to bust that battery and blow my ME66?



Return to posts index

Ernie Santella
Re: SDX900 Battery Issues and Questions
on Jul 28, 2009 at 5:33:26 pm

Aaah, more to the story. A short in the Gold-mount could have certainly done some damage to the Battery. I might be worth shipping the battery to the manufacturer to test. Most new batteries have electronic chips in them for control/display etc. You might have done some damage.

Ernie Santella
Santella Productions Inc.
http://www.santellaproductions.com


Return to posts index


Temesgen Asmerom
Re: SDX900 Battery Issues and Questions
on Aug 17, 2009 at 11:24:20 pm

I'm sure you've resolved by now, but just in case,

In response to your first issue, running your frezzi on the Dionics is not recommended by Anton Baeur. Their Lithium Ion line(dionics) aren't really built for that. THe ProPacs are the real workhorse, but not optimal. Hytrons also work fine. But with the Dionics not only do you get a short run time, but your also decreasing the life of the battery with each drain.

On the second note, it may be possible to reset the battery from it's current flashing state. Take a paper clip and dip it into the tiny hole just below/above the LED display.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]