FORUMS: list search recent posts

Problem with looping video in flash using cue points

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Luther VanDam
Problem with looping video in flash using cue points
on Mar 17, 2013 at 5:07:07 pm

OK, so I have actually found the answer to this on this forum a year ago. I got it to work on my site, but now, I try it in a new flash project, and no dice. I get an invalid seek error. The effect I am going for here is to simply have an external FLV play, then loop back to the middle, so it constantly cycles between the middle and the end. The only difference I can see between my published site and the new one is that the video streams from an FTP on the published site. This shouldn't matter, should it? If anyone could clue me in on how to fix it, I will be your best friend forever. Thanks

And here is my code



stop();


import fl.video.MetadataEvent;


Movie.addEventListener(MetadataEvent.CUE_POINT, loopFunction);
function loopFunction(e:MetadataEvent):void{
if (e.info.name=="introEnd") {
Movie.seekToNavCuePoint("introMiddle");
Movie.play();
}
}


Return to posts index

Luther VanDam
Re: Problem with looping video in flash using cue points
on Mar 17, 2013 at 5:46:39 pm

Oh, and I am using embedded cue points. Sorry I forgot to add this.


Return to posts index

demetri tashie
Re: Problem with looping video in flash using cue points
on Mar 18, 2013 at 2:39:34 am

most likely somthing did actually change. did you reconvert/re-ouput the flv? is 'introMiddle' really a navigation type cue point and not mistakenly an event type cue point?

double check to see that there really is a navigation type cuepoint named 'intoMiddle'.


Return to posts index


Luther VanDam
Re: Problem with looping video in flash using cue points
on Mar 18, 2013 at 3:25:35 pm

So I went home and was using CS 5.5 for premiere and for flash. When I opened up the FLV )that was rendered in premiere CS 6) in flash CS 5.5, it read all the cue points as event cue points. I thought I messed it up and just pulled a bone head mistake. I went back to school, and opened up the old files in CS 6 to see if I screwed up, and they were showing as nav cue points, not event cue points. I am not sure if Adobe messed something up, but it does not work in CS 6. Looks like I will be doing a lot of work from home.


Return to posts index

demetri tashie
Re: Problem with looping video in flash using cue points
on Mar 18, 2013 at 8:46:11 pm

odd

could be a bug, or somethng else. i don't know. anyoane else have any ideas??

i would think that an flv rendered from whateer version is independent of that version. i would suspect more that maybe the flash player version or the FLVPlayback component( if you are using one) might be more likely to be the culprit and be finicky about the version.


Return to posts index

Luther VanDam
Re: Problem with looping video in flash using cue points
on Mar 18, 2013 at 10:10:40 pm

I am not sure. All I do know is that when I rendered it out in CS 5 premiere, it worked fine in flash cs 5 and cs 6. No issues. I wrote to my IT guy at Carnegie Mellon, and he said he came across this response from Adobe:
"I can't give specifics about fixes or features coming in future versions, but I did want to give an update on this. We are working on a fix for this, and we are hoping to make it available in the near future. Again, I need to stress that I can't make specific promises about what will be in which version and when, but I wanted to make sure that you knew that we are absolutely not ignoring this issue."

So hopefully it will be fixed soon. Thanks again for your attention to this problem. If I hear anything, I will post. Thanks!


Return to posts index


demetri tashie
Re: Problem with looping video in flash using cue points
on Mar 19, 2013 at 12:52:29 am

well that narrows it down : - )


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]