FORUMS: list search recent posts

URL links work in test but not in actuality - AS3.

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tim Quinn
URL links work in test but not in actuality - AS3.
on Feb 20, 2013 at 3:33:12 pm

Action Script 3- I have URL links set up on buttons and TLF text. When I test the movie in Flash the links behave as expected. All the websites open up without an issue. However, when I open the .SWF file from Windows Explorer, none of the links function. I did find the answer to how to fix the URL links by setting the Publish settings Local Playback Security to "Access Network Only" but now my internal linkage system doesn't work.
The way my program works is:
I have buttons that import an external SWF file through the "addchild" script. Then inside the loaded swf there are text links that point to URLS. With the 'Local Playback Security' set to "Access Local Only" the program will load the external SWF files but not link to the URLS. Then if I set the 'Local Playback Security' to "Access Network Only" the program will not load the SWF files; but when I open the SWF in explorer, the links work. I need both to work. I think it's dumb that there isn't an option to "Access both Local and Network"

Is there another way to fix this?

If you need to see code I can post it, but it is the most basic way to make these actions work. I'm just learning.

Thanks in advance to any help.
Tim


Return to posts index

Tim Quinn
Re: URL links work in test but not in actuality - AS3.
on Feb 20, 2013 at 6:29:11 pm

After thinking about my post I realize there are a few details I need to add. First I said I use the "addChild" script. This is true but I also use the videoLoader in conjunction with it. I tried to set up classes to simplify everything but I could not get them to work. So programmed everything the long way.

Example:

var safeMedLoader:Loader = new Loader();
var safeMed:URLRequest = new URLRequest("safetyMedical.swf");
safeMedLoader.load(safeMed);
addChild(safeMedLoader);


The setup is this:
Lvl1 is the Main Menu page with links to social media sites thru button URL links. Other buttons load SWF files using the code above. Those Lvl2 Menus then load Lvl3 content pages. The Lvls 2 pages need work locally, Lvl 3 pages need to work on the network, and Lvl 1 has to function on both local and network. I've tried setting Lvls 1 & 2 to function this way but it doesn't work.

The primary functionality is to be played from a CD or DVD. I want people to be able to run the program from a disk and access the internet from the links thereon. Web functionality for the program is a secondary issue.

I'm at a loss as to how to bypass these security settings.Please help!!


Return to posts index

Mike Smith
Re: URL links work in test but not in actuality - AS3.
on Feb 21, 2013 at 9:53:58 am

Or you could look at http://labs.mstudio.com/?p=31 alongside the adobe help. There are decent reasons for the security sandboxing.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]