FORUMS: list search recent posts

Imported video problems.

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tor Westerlund
Imported video problems.
on Mar 15, 2010 at 12:34:16 pm

Hello.



I am making a website like presentation in flash and I am having some very annoying problems...



What I am trying to do is making a video which I've imported as a video(located at frame 2) with external playback components using no skin at all to go from start to finish and after playback I want it to automatically jump to the next frame in my presentation (3). I can't get it to work, wasted 6 hours and not a shade of success... Using Actionscript 1.0 & 2.0 in Adobe Flash CS4. The video is in 1080p and I can't sacrifice that, it's 22 seconds long.



I've gotten everything to work except this part.



Source file:
[url]http://www.2shared.com/file/12117444/52cf8af/presentation.html[/url]



I am near my limit here, if someone could help me I'd be forever grateful!


Return to posts index

Brodd Nesset
Re: Imported video problems.
on Mar 15, 2010 at 8:38:32 pm

1080p video is a very modern feature. ActionScript 1.0 is like ten years old. Flexible as the Flashplayer is, this could still be stretching it a bit too far. My two cents anyway.

Using ActionScript 3 (which already is three years old), I would:

1. Name the video component something, like 'vid'

2. In frame 3:

Stop();
vid.addEventListener("compelete", goOn);
function goOn(e:Event):void {
play();
}

...it's not that difficult scripting, is it? I ask, because the mytihcal 'difficultness' of AS3 is the only sensible reason I can see for sticking to older versions. And: it's just a myth...

PS you need to set up your file for AS3 scripting only for this to work, of course.



Not everything that can be counted counts, and not everything that counts can be counted.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]