FORUMS: list search recent posts

vanishing symbols

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
David Schuster
vanishing symbols
on Nov 2, 2009 at 4:56:58 pm

Why when editing a symbol, does it disappear when I rotate it?
Its a single character of a font and each time I try to rotate it in a nested animation it vanishes leaving only the bounding box and a small circle at the center.
It doesnt seem to matter whether the object is saved as a graphic or a movie or if I try and edit only the instance.
What am I doing wrong?
Thanks,


DS


Return to posts index

cowcowcow
Jen deHaan
Re: vanishing symbols
on Nov 3, 2009 at 2:36:59 am

My guess is that you're using dynamic text fields. Make sure that you embed your fonts, and then you can rotate the fields without the text disappearing.

-----
Jen
http://www.flashthusiast.com


Return to posts index

David Schuster
Re: vanishing symbols
on Nov 3, 2009 at 5:21:25 pm

In the Properties pallet its showing as "Static Text". Even when I turned it into a bitmap it dissappears as soon as I manipulate it. This happens whether I'm animating on the main timeline or making it a nested timeline.

DS


Return to posts index


cowcowcow
Jen deHaan
Re: vanishing symbols
on Nov 3, 2009 at 9:23:29 pm

Ah, forgot to mention device fonts. Are you using a device font with your static field? You will need to use a non-device font to do such manipulations. Here's some info on text in flash in case it helps: http://kb2.adobe.com/cps/154/tn_15403.html

-----
Jen
http://www.flashthusiast.com


Return to posts index

David Schuster
Re: vanishing symbols
on Nov 4, 2009 at 8:25:21 pm

These are good thoughts Jen, but I'm using a downloded font that is not a system font. Is there anything specific I need to do to "embed" or outline the font besides just not selecting dynamic, input or system fonts? I figured turning it into a symbol would handle that for me.

DS


Return to posts index

cowcowcow
Jen deHaan
Re: vanishing symbols
on Nov 4, 2009 at 10:17:47 pm

A downloaded font can be set to device fonts in anti-alias, that would disappear. Make sure that's not the case.

Those are the most common cases. If you're using static text and it's not set to or using device fonts, then it should appear. You might want to link to the file for download, it'd be easier to troubleshoot.

-----
Jen
http://www.flashthusiast.com


Return to posts index


David Schuster
Re: vanishing symbols
on Nov 5, 2009 at 7:15:32 pm

Yeah, its set to Static Text and the antialias is set to Antialias for Animation. So Im clueless. I am also finding that when I'm working with symbols and I need alpha settings they don't show up in Properties, and when I need Rotation it doesnt show up there either. Doesnt seem to matter how many tutorials I go through. Nobody is addressing this. I'm obviously doing something wrong, or theres a problem with my installation of Flash CS4. I wasting a ton of time...

DS


Return to posts index

cowcowcowcowcow
Jen deHaan
Re: vanishing symbols
on Nov 5, 2009 at 8:00:44 pm

Well the Property inspector is context sensitive, and it really depends on your selection for what shows up. (Text instances have filters but not color effects, MCs have both, Graphics have color effects.)

Rotation will show up in the PI when you select a tweened frame, not the instance. But you can rotate an instance if you use the free transform tool. Or you use the Transform panel.

Again if you can share your file, this would help troubleshoot a lot quicker.

And as a longtime tutorial and doc writer, it's very hard to put complete troubleshooting alongside the steps (guessing all the variables). You basically give the steps and related info that are hopefully correct and cover most queries, and this would only provide the most common cases - tutorial/blog comments and forums like this (and tech support etc) are for addressing the rest. And Flash is so complex, no one tutorial can cover it all. This doesn't apply to bad tutorials of course.

-----
Jen
http://www.flashthusiast.com


Return to posts index

David Schuster
Re: vanishing symbols
on Nov 5, 2009 at 8:24:06 pm

Thanks Jen for your help on this. Some of what you said clears a few questions up for me about what should show up in the properties panel and when. I'll see about getting the file uploaded somewhere and provide a link. I've done a few moderately complex animations in CS3 but I'm still a noob and CS4 is messing with my head. It wont even consistantly allow me to name layers!

DS


Return to posts index


Jen deHaan
Re: vanishing symbols
on Nov 5, 2009 at 9:04:13 pm

If you're meaning that the layer name closes before it allows you to type in, make sure you don't have the Behaviors and Actions panels open at the same time. (That was a known issue that'll be fixed in a future release).

-----
Jen
http://www.flashthusiast.com


Return to posts index

David Schuster
Re: vanishing symbols
on Nov 6, 2009 at 3:17:37 pm

Yes thats what it was doing. I don't think I had both open at the same time but the behaviors panel was open. So thats good to know.

DS


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]