FORUMS: list search recent posts

XML and Flash

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Joshua Altman
XML and Flash
on Oct 10, 2009 at 1:05:14 am

I am trying to create a flash movie using ZML data sheets, but whenever I put a link to a webpage in my XML it keeps the .swf from working. I have been searching around the web and there is no one answer to the problem, and none of the solutions out there seem to be working for me, any ideas will be much appreciated.


Return to posts index

Mike Smith
Re: XML and Flash
on Oct 12, 2009 at 9:10:13 am

What exactly is the problem?

Your xml is compliant - "well formed", right?

Then are you succeeding in parsing the incoming xml and putting the data elements from it into Flash variables? If so, are your variables holding web addresses then not responding to a getURL, or to some other actionscript command? If so, have you made sure that the command is dalayed until the xml is loaded and parsed ..?

http://www.developer.com/open/article.php/797861/Well-Formed-XML.htm

http://www.xml.com/pub/a/tools/ruwf/check.html



Return to posts index

Joshua Altman
Re: XML and Flash
on Oct 12, 2009 at 3:19:00 pm

Thanks

The XML and the AS are both well formatted, if I leave out my attempts in the XML to create a link everything works perfectly, it is only when I begin to add in the links that things fall apart.

I have been including various attempts at HTML in the XML document, not Action Script (AS2). Do I need to include AS in my XML, or in my actions layer of my flash file for it to recognize a link.


Return to posts index


Mike Smith
Re: XML and Flash
on Oct 12, 2009 at 4:49:31 pm

OK. Your actionscript needs to be in your Flash file.

You could have a look at xlink I guess ... http://www.w3.org/TR/2001/REC-xlink-20010627/ ... though whether the Flash player will recognise and respond to xlink appropriately I don't know. Maybe it will will work. There's an example of sorts that might help at http://livedocs.adobe.com/flash/9.0/main/wwhelp/wwhimpl/common/html/wwhelp....

Otherwise, your xml is only going to hold your link destination; you're going to pass that information as a variable to an actionscript function that will then generate or call the link.

If you reduce your included link to simply the destination, can you still get the xml to report as well formed? T


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]