FORUMS: list search recent posts

SWF shows only briefly

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris Bridges
SWF shows only briefly
on Aug 23, 2009 at 3:13:54 am

Hi all,
I have some SWF files as headers on my website. Everything worked great until recently. If I clear the browsing history in IE, then load my website, the SWF on the index page shows briefly (sometimes not at all) then does not show. If you reload the page it works fine. If you go to another page first, it works OK as well. It seems to work OK in Firefox. It seems to do this mainly after clearing the browsing history. You can see the site at http://www.auburnillinois.us

Any ideas?
Thanks


Return to posts index

Chris Bridges
Re: SWF shows only briefly
on Aug 23, 2009 at 3:03:04 pm

Found another issue that may help. I added accuweather to my site. If I remove the accuweather code, the flash file loads. If I add it back to the site, the flash header goes away. Here is my accuweather code<div style='width: 120px; height: 60px; background-image: url( http://vortex.accuweather.com/adcbin/netweather_v2/backgrounds/blue_120x60_... ); background-repeat: no-repeat; background-color: #346797;' ><div id='NetweatherContainer' style='height: 48px;' ><script src='http://netweather.accuweather.com/adcbin/netweather_v2/netweatherV2ex.asp?partner=netweather&tStyle=whteYell&logo=0&zipcode=62615&lang=eng&size=7&theme=blue&metric=0&target=_self'></script></div><div style='text-align: center; font-family: arial, helvetica, verdana, sans-serif; font-size: 10px; line-height: 12px; color: #FFFFFF;' ><a style='color: #FFFFFF' href='http://www.accuweather.com/us/IL/AUBURN/62615/city-weather-forecast.asp?partner=netweather&traveler=0' >Weather Forecast</a></div></div>

Can anyone figure this out?
Thanks
Chris



Return to posts index

Pieter Helsen
Re: SWF shows only briefly
on Aug 23, 2009 at 3:17:20 pm

Try setting the wmode setting for your header to window instead of opaque.

wmode settings are dodgy at best.

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index


Chris Bridges
Re: SWF shows only briefly
on Aug 23, 2009 at 10:23:34 pm

I tried changing the wmode to window and it still didn't work. I changed it in the file itself after inserting it into dreamweaver. I don't know if that is the best way to do it or not.

Here is what I did to get it to work (for now). I removed the div id (id='NetweatherContainer') out of the accuweather weather bug and now the flash header loads. Can anyone exlpain why that worked?

Thanks
Chris


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]