FORUMS: list search recent posts

Thanks everyone and one more problem

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris Poole
Thanks everyone and one more problem
on Oct 10, 2008 at 6:03:05 pm

Hi Everyone,
Just want to say thanks for all your help to date! It's been an education learning flash by jumping right in... I have to admit I love this program.

I have one more crazy problem;

http://www.spotcheckservices.com/~~~newspotcheckweb/spot%20check%20eng-fr.h...

If you go to the site above and click on English, you will see the main flash page with 6 big square buttons on the rotating pic. Above that I have added some quick jump button so you can navigate the site without having to go back to the main page all the time to see about us, service, the team, etc...

Here is the problem I am running into:

I have tried creating the new buttons that go along the top as a: movie clip and b: buttons.

here is the script ( action script 2.0) for them

Button: services button
on (release) {
_root.gall_num = 2;
_root.play();
}

Button: about us button
on (release) {
_root.gall_num = 1;
_root.play();
}

Movie Clip:

onClipEvent (load) {
num = 6;
this.point1.title01.title1.gotoAndStop(num);
this.point1.title01.title2.gotoAndStop(num);
this.point1.point2.gotoAndStop(num);
}
on (rollOver) {
this.point1.gotoAndPlay("s1");
this.point1.title01.gotoAndPlay("s1");
}
on (releaseOutside, rollOut) {
this.point1.gotoAndPlay("s2");
this.point1.title01.gotoAndPlay("s2");
}
on (release) {
gotoAndPlay("s1");
_root.gall_num = 4;
_root.play();
_parent.item2.gotoAndPlay("s1");
_parent.item1.gotoAndPlay("s1");
_parent.item4.gotoAndPlay("s1");
_parent.item5.gotoAndPlay("s1");
}

I should also mention that I copied the movie clip script from the 6 burgandy square buttons.


Every time I click on the new buttons along the top it automatically jumps back to the main page then I have to click it again to get where I want to go. I am trying to skip first click that takes me back to the main page and just have it go where I want it to go.

Can you see anything wrong with my script? either for button or movie clip.

I should mention that this was a template that I bought.

Thanks again for all your help.

Cheers
Chris



Return to posts index

Chris Poole
Re: Thanks everyone and one more problem
on Oct 14, 2008 at 12:47:18 pm

Hi Everyone;

Thanks again for all your help, and I want to make a note that Sam has been a wonderful resource. I tip my hat to the people who reply on these forums, you show amazing patience and skill to take a program and make it into English for us newbies...

Here is the behavior that turned out to work,

on (release) {
_root.gall_num = 2;
_root.gotoAndPlay(96);
}

For anyone buying a template and attempting to add there own buttons to link to other pages in the file. (96) refers to the frame when the content pages start to play.

Cheers
Chris



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]