FORUMS: list search recent posts

Flash Video Play Troubles

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Lisa Hurley
Flash Video Play Troubles
on Aug 11, 2008 at 7:16:51 pm

Hello..I am fairly new to flash, and am mostly interested in it for it's video capabilities. I have been able to successfully encode video avi files via flash and upload them thru Dreamweaver for viewing on the web, but my latest project has turned out to be quite frustrating. I have created a very simple web page in flash, which only includes a menu where each button points to a different video. I have finally got it just perfect (in my pc that is).. because when I view it locally, it looks just fine. But when I look at it online, all that shows up is my menu... no video. I have tried everything I can think of.. I am seeing one html file and a .swf file that was generated by Flash when I published / exported. My movie files were already on this site. Could it be the location of the movie files? And if so, will moving the files around make the video work? How should the files be on the server? Please help!!!


Return to posts index

Lisa Hurley
Re: Flash Video Play Troubles
on Aug 12, 2008 at 3:27:54 pm

UPDATE: While going through a tutorial, I have noticed that Flash is supposed to export a .js file along with the .swf files. For some reason, I didn't get one. Wouldn't it have been exported to the same location as the .swf files if one had been generated? Does anyone out there know? Thanks!!



Return to posts index

Pieter Helsen
Re: Flash Video Play Troubles
on Aug 12, 2008 at 3:54:15 pm

It only generates a .js file if you export an .html file aswell. And Adobe only introduced the AC_RunActiveContent.js file with their CS3 release. Flash 8 does not need a file like that.

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index


Lisa Hurley
Re: Flash Video Play Troubles
on Aug 12, 2008 at 4:11:25 pm

Well.. do you have any clue as to why a video (flv) will not show up online, but plays fine otherwise?



Return to posts index

Pieter Helsen
Re: Flash Video Play Troubles
on Aug 12, 2008 at 4:21:16 pm

Make sure the .flvs are in the same folder. And make sure the video path doesn't contain any references to localhost or whatever.

If that doesn't work, tell me what your filestructure looks like (which files are on the server and in what folders) and send me the link so I can have a look. Also, if you can, upload the .fla and I will have a look.

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index

lisa hurley
Re: Flash Video Play Troubles
on Aug 14, 2008 at 1:33:30 pm

Thank you so much. I was finally able to get things on the right track. I discovered after reading what you had to say, and after working with the files I had uploaded... that things pretty much have to be exactly right, and in the right order, or it's not going to work.
Here is a link to the site:
http://bluemediamagic.com/media/dance_recitals/Amys_School_Of_Dance/flash/a...
I'd be very grateful if you could steer me in the right direction, as to what I need to do to get the videos to stop playing with the user clicks on a different video. At this point, if a video is not finished, and another video is pulled up, the previous one continues to play.
Also, another major concern is the length of time it takes to pull these videos up. I was under the impression that by using Flash for these videos, that "all" of the videos would not have to load, ... only the ones that the user chooses... but it appears that ALL of the videos are trying to load into the page.
Any input you might have would be GREATLY APPRECIATED!!!!!
Lisa



Return to posts index


Pieter Helsen
Re: Flash Video Play Troubles
on Aug 14, 2008 at 1:40:05 pm

Wow, it's definitely loading all the videos... :)
Let me have a look at the .fla and I'll see what I can do.

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index

lisa hurley
Re: Flash Video Play Troubles
on Aug 14, 2008 at 1:44:22 pm

Crazy Question: How do I get the .fla to you? :)



Return to posts index

Pieter Helsen
Re: Flash Video Play Troubles
on Aug 14, 2008 at 1:50:33 pm

Either just upload it to your webspace or, send it via mail :)

doccie |AT| gmail |DOT| com

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]