FORUMS: list search recent posts

almost embarrasing struggle with embedding

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
calvin remsburg
almost embarrasing struggle with embedding
on Jul 28, 2008 at 5:34:12 pm

for some reason i cannot load my flash movie onto the web. here's how i've got my site setup:

root directory with the folders of CSS, IMAGES, FLASH, and the index file.

perhaps the problem is elsewhere than the code. in Flash, my movie works fine. I publish it, then upload it to my server. from there it no longer works, it's an empty frame. what gives?

what am i doing wrong?


Return to posts index

Pieter Helsen
Re: almost embarrasing struggle with embedding
on Jul 28, 2008 at 11:57:04 pm

Err, well... A link would be helpful :)

I'm thinking you missed a few references to the source. There's about four places where you need to point HTML/Javascript in the direction of the source file.

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index

calvin remsburg
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 4:20:22 pm

okay, a little delayed but here i am.

link:

http://www.hobbesplayground.com

the flash is a file that's 800 x 150, which falls right under the nav bar.

before i load it, the file works just fine in flash, but after i upload it, the file appears to be nothing, empty

the actual file is @

http://www.hobbesplayground.com/flash/logo.swf

if you look at it, there's nothing there. ???



Return to posts index


Pieter Helsen
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 4:32:51 pm

That's a problem with your flash movie... Did it generate any compiler errors when you tested it? Are you loading other .swfs or maybe .flv movies into the swf?

Can you upload the .fla file?

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index

calvin remsburg
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 4:51:14 pm

i'm importing an after effects file into the flash file. the only way i've found that makes this look nice is by exporting the ae file as a .mov file, then importing it into my .fla file.

do you know of any other way around that?



Return to posts index

Pieter Helsen
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 4:52:06 pm

I'm guessing you need to upload your .mov file as well. :)

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index



Pieter Helsen
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 5:38:25 pm

Here we go.

Download both these files, open the .fla in flash and publish the movie to get the .swf. Upload both the .flv and the .swf to your server for it to work.

http://www.pieterhelsen.be/cow/logo.fla
http://www.pieterhelsen.be/cow/logo.flv

The second one is a flash video file, created from your .mov. If you feel the quality is inadecuate, this is what you can do:

Open up your logo.fla in flash. Delete all the content from the stage. Then go to File > Import > Import video...

Use these settings:
- On your computer: browse to find the logo.mov file
- Progressive download from webserver
- Encoding profile: Flash 8 - High Quality
- Skin: None
- Finish!

This will, again, generate a logo.flv file for you with a better quality (I used the standard 400kbps data rate instead of the 700kbps)

Good luck.

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index

calvin remsburg
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 6:29:06 pm

thanks, but the .fla file only will save as a text file.

what, if any, changes did you make to have this work? i appreciate it, but i'd also like to know what i was doing incorrectly.



Return to posts index


Pieter Helsen
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 6:30:31 pm

Basically all I did was start a-fresh. Going through the steps I listed in my previous post. :)

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index

calvin remsburg
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 6:42:15 pm

the steps you mentioned are exactly how i executed my file earlier. i've repeated as you mentioned (with my original fla file) and i'm still getting the same result. any idea?



Return to posts index

Pieter Helsen
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 6:46:28 pm

http://www.hobbesplayground.com/flash/logo.flv
The requested URL /flash/logo.flv was not found on this server.

Upload the .flv aswell...

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index


calvin remsburg
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 6:59:45 pm

alas, some progress! HALF of the swf loaded, that's a start.



Return to posts index

Pieter Helsen
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 7:10:28 pm

How do you mean, half? It looks good here.
If you mean the words 'chefs network' being displayed from the beginning... That has to do with your After Effects movie, not the flash file.

Kind regards,
Pieter

General notice: from now on, I would like to ask everyone to put [AS2] or [AS3] (corresponding to the version of actionscript you are using on your project) in front of their post titles when the question is actionscript related! Please help us help you faster. Thank you.


Return to posts index

calvin remsburg
Re: almost embarrasing struggle with embedding
on Aug 4, 2008 at 7:14:49 pm

from here all i see is the words 'chefs network', the first word isn't animated or even present in the swf.

i'll look into my ae file.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]