FORUMS: list search recent posts

Problem with FLV cue points in multiple scenes

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Adam McGilvray
Problem with FLV cue points in multiple scenes
on May 30, 2008 at 2:49:20 pm

I'm trying to set up a webinar, talking head video with animated text to the side set to cue points embedded in the flv. I've got 8 scenes set up, each with a different flv. My first scene plays perfectly and advances to the second scene. The video starts playing but exactly at the point of the first cue, the text animation begins but the video disappears. The timeline stops, then after a pause, the video starts at the beginning a loop beginns. I can test all the scenes individually in Flash and they work perfectly. This only happens when I test the movie (or publish it).

Here's my AS3 in the first frame of scene 1:

import flash.display.MovieClip;
stop();
function flvListener1(eventObject:Object):void {
if (eventObject.info.name == "systems") {
gotoAndPlay(89);
};
if (eventObject.info.name == "success") {
gotoAndPlay(2);
};
if (eventObject.info.name == "end") {
gotoAndPlay(166);
};
};
vid_Bill1.addEventListener("cuePoint", flvListener1);

For the "end" - I move to a point in the timeline where everything fades out and actionscript in the last frame removes the event listener and the gotoAndPlay to the next scene.

All other scenes set up similarly.


Return to posts index

Adam Ashby
Re: Problem with FLV cue points in multiple scenes
on May 30, 2008 at 7:09:19 pm

2 suggestions:

use
this.gotoAndPlay(89);

0r label your frames
gotoAndPlay("systems");

Naming frames always seems to work better. Plus, if you change things around, make timelines shorter or longer, you don't have to adjust the ActionScript, just move the frame label to the right place.

Adam Ashby
mutli-media artist
http://www.adamashby.com

fdcproductions.com


Return to posts index

Adam McGilvray
Re: Problem with FLV cue points in multiple scenes
on May 30, 2008 at 7:25:28 pm

Thanks! Good suggestion. Unfortunately it didn't fix my problem.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]