FORUMS: list search recent posts

Why can't I get my list to pass a URL to my video player?

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
BrentC
Why can't I get my list to pass a URL to my video player?
on Jul 19, 2007 at 6:27:45 pm

I'm a flash newbie who's in way over his head. I'm trying to create a simple video player that loads a list of clips from an XML file. I have an XML connector component pointing to my XML file, which is bound to a listbox component. The values pass fine into the listbox, but my problem is in passing URLs to the video player.

In my XML file, the video references are in an attribute tagged "url". I have "selectedItem:Object" bound to "contentPath" on my video player. Then the formatter is set to "Rearrange Fields" with the code "contentPath=url". When I test the movie with debugging turned on, everything runs fine until I select a clip from the list. At that point it returns:

7/19 11:23:0 Executing binding from list:selectedItem:- to playback:contentPath:-
7/19 11:23:0 Assigning new value '-' (-)
Error opening URL "file:///C|/Documents%20and%20Settings/.../undefined"

Can someone tell me what I'm doing wrong here?


Return to posts index

BrentC
Re: Why can't I get my list to pass a URL to my video player?
on Jul 19, 2007 at 8:44:00 pm

Never mind, I got it. Figured out that the contentPath has to be bound to the XMLConnector "url" schema, and the index bound to the list box's currentItem. That did the trick.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]