FORUMS: list search recent posts

??? fun with an XMLNode...

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
DonnoMan
??? fun with an XMLNode...
on Feb 5, 2007 at 11:23:55 pm

Figure out this one if you will. Code is given below. "page" is an instance of a class I have defined. This class works great. "page.xml" points to an xmlNode. "_root.trace("page.xml = " + page.xml);" gives me the exact output I'm looking for. However...the following traces say undefined. I say this is a Flash bug. *****Note that the if() condition DOES return true and the code block DOES run...and look at what the condition is, especially what it looks at in the Boolean comparison.***** Any suggestions on how to hack around this?

if(page.xml.firstChild.nodeName == "options"){
_root.trace("This page is for mcFeedback!!!");
tempURL = page.xml.firstChild.childNodes[f_subPage].childNodes[4].attributes.url;
_root.trace("page = " + page)
_root.trace("page.xml = " + page.xml);
_root.trace("page.xml.firstChild = " + page.xml.firstchild);
_root.trace("page.xml.firstChild.childNodes = " + page.xml.firstchild.childNodes);
_root.trace("page.xml.firstChild.childNodes[f_subPage] = " + page.xml.firstchild.childNodes[f_subPage]);
_root.trace("page.xml.firstChild.childNodes[f_subPage].childNodes = " + page.xml.firstchild.childNodes[f_subPage].childNodes);
}


Return to posts index

DonnoMan
Re: ??? fun with an XMLNode...
on Feb 5, 2007 at 11:43:29 pm

Do not reply to this topic. I feel dumb now. I have run into problems like this before...but those times I didn't have any problems with capital/lowercase letters like this time.

There's no problem. (Although I still can't get to work the think I was tracing out that information about...)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]