FORUMS: list search recent posts

xml video playlist won't buffer between clips...?

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
dflamholc
xml video playlist won't buffer between clips...?
on Aug 22, 2006 at 11:56:49 pm

Hi all, i've done lee brimelow's tutorial by the book and it works, all but the buffer clip which will only show as the first clip loads as the page loads, after that, when one clicks a new clip in the list the clip loads, the progress bar loads, but the buffer clip won't come back. the net connection command and all it's properties is not my strong side in flash so i don't really know what it is I should tamper with. any suggestions or advice much appreiciated. thanks in advance for any help, best /david


Return to posts index

jhunyadi
Re: xml video playlist won't buffer between clips...?
on Sep 5, 2006 at 6:27:40 pm

I had that problem too...

//I changed this code:

if(info.code == "NetStream.Buffer.Empty") {
bufferClip._visible = true;
}

//to this:

if(info.code !== "NetStream.Buffer.Full") {
bufferClip._visible = true;
}

no problems yet, but I just did it.

- Joshua


Return to posts index

lajoiet
Re: xml video playlist won't buffer between clips...?
on Sep 5, 2006 at 8:52:44 pm

I wouldn't suggest using that code. when you say:

if(info.code !== "NetStream.Buffer.Full") {

you're saying that EVERY TIME the code is NOT "NetStream.Buffer.Full" you want the buffer clip to be visible, but there are many codes:

NetStream.Buffer.Flush
NetStream.Play.Start
NetStream.Play.Stop
NetStream.Seek.InvalidTime
NetStream.Seek.Notify

which could be fired for any number of reasons during playback, in this case, one of those firing would cause your buffer clip to be visible and it would not go away again until the "NetStream.Buffer.Full" message was send again, which won't happen unless the buffer gets emptied out, which rarely happens once it's started playing unless the user is on a slow connection.

A better way to do it is to go through your code and anywhere that you start a new video playing with the:

ns.play("whatever.flv");

you make the buffer clip visible after that line. That way each time a new video is started, the buffer clip is made visible, and it doesn't go away until the buffer is full and playback starts.

>Todd
_____________________________________

I'm filling a need. Without me there would be no bad examples.
_____________________________________


Return to posts index


jhunyadi
Re: xml video playlist won't buffer between clips...?
on Sep 6, 2006 at 6:00:32 pm

makes sense...

I was curious why it was working. I tried it on a whim (obviously I'm newbie too).
Thanks - your posts always help!

Joshua


Return to posts index

jhunyadi
Re: xml video playlist won't buffer between clips...?
on Sep 6, 2006 at 6:08:59 pm

Yeah, it worked perfectly... and so simple.

Thanks Todd!!!


Return to posts index

lajoiet
Re: xml video playlist won't buffer between clips...?
on Sep 6, 2006 at 6:09:25 pm

You probably just got lucky and none of the other status codes ever got fired.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]