FORUMS: list search recent posts

help - "bitmap not loaded" repeated error!

COW Forums : Adobe Flash

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
His Dudeness
help - "bitmap not loaded" repeated error!
on May 29, 2006 at 3:49:41 pm

Hi,

I keep getting this random problem, wondering if anyone would be kind enough to help me out. I load a series of 400ish PNG frames onto the flash timeline. They are all fine, except frame 365 which never seems to load! I get a blank frame on the timeline and in the library when i click on the corresponding bitmap it says "bitmap not loaded" or something like that. I hit 'update' and voila! it magically appears and all is well again. I then save the flash file but the next time i open it - same problem: bitmap not loaded again! Its always this one frame but i dont see what's different about it. It was one of hundred of frames rendered off in 3D Studio Max and shouldnt be any different to any of the others. It also opens fine in picture browsers and photoshop.

The same problem also happens in another flash file. A series of hundred of images but 1 random image never seems to load properly.

Is this a problem with memory, the file itself?

Any help at all would be greatly appreciated!

Sandy


Return to posts index

thumbslinger
Re: help - "bitmap not loaded" repeated error!
on May 30, 2006 at 4:25:45 am

I had a similar problem, but it was a different frame number and turned out to be a memory issue.

However, though this isn't what you're looking for, what version of Flash are you using? Can you render out a QuickTime movie and then convert it to an flv? You're Flash file itself must be huge and possible slow as you edit?

Anyway, I've really started to use flv much more lately and learned how to control them via actionscript with cues and all because importing bitmaps just opens a can of worms.

You can also research "Cache as Bitmap" to help if you're using any frames out of sequence.


Return to posts index

His Dudeness
Re: help - "bitmap not loaded" repeated error!
on May 30, 2006 at 11:14:06 am

Thanks for the reply. I'm using Flash MX Pro 2004. I do get a memory error when i try to open the file's library. Something about increasing memory which im not entirely sure how to do. I've cropped all the frames as close to the character as possible to minimise file size (they arent 800x600 or anything) but like you say, things are pretty slow.

I'm interested in the whole FLV thing you mentioned though. It would be easy for me to render out the animations in Max as pretty much any video format instead of the PNGs. What would be the pro's and con's of using video vs bitmap sequences? The only problem is i need the images/video files to have alpha channels (transparent backgrounds) - hence the PNG format im currently using. Is it possible to include alpha channels in video files?

Cheers,

Sandy


Return to posts index


cowcowcowcow
thumbslinger
Re: help - "bitmap not loaded" repeated error!
on May 30, 2006 at 7:15:24 pm

With the new Flash 8, you can encode a video file with an alpha channel by indicating it in the conversion process.

I'm not sure about other programs that create an flv but using the Flash 8 encoder that comes with Flash 8 you can specify the alpha channel.

If you can render out a quicktime file with an alpha channel and post it somewhere, I'll convert it to an flv for you.

The pros are much smaller file size; the video will stream nicely instead of having to be preloaded and your fla file will be much smaller.

Not knowing what you're trying to accomplish with the imagery within the flash app, I can't think of too many cons with doing this.

The Flash 8 player is usually required but by now so many have upgraded to that plug-in and new browsers are shipping with it that it's somewhat of a stretch to find a con.

Again though, that's not knowing how much control you want over the movie.

If you do post a file somewhere for me to download, you can let me know at kelly@thumbslinger.com

I'll check that later tonight.


Return to posts index

His Dudeness
Re: help - "bitmap not loaded" repeated error!
on Jun 2, 2006 at 3:19:30 pm

Unfortunately the project has to be playable with the Flash 7 player, so i guess the FLV thing is out the window then??

I actually managed to fix the 'file not loaded' problem eventually. I rerendered the specific frames in Max and now they seem to load in Flash just fine for some reason! Must have been a problem with corrupt files or something i guess. Very strange none the less.

Thanks for the FLV encoding offer - i really appreciate it. Hopefully i'll get by ok using hundreds of individual frames as opposed to video.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]