FORUMS: list search recent posts

Still can't export with transparent background

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Kay Ghey
Still can't export with transparent background
on May 2, 2017 at 1:04:54 am

Hi guys,

I'm a long time lurker but have finally achieved a level of frustration that's driven me to creating an account.

I'm spent hours today scouring the internet for some new solution to exporting out of Motion 5 with a transparent background.

I've taken all the steps that I could find:

1. Background settings to transparent
2. Exporting in Proress 4444
3. Export set to "Color + Alpha"

and despite my best efforts, I still can't find a way to get it into FCPX with a transparent background.

I've also tried saving the project file and pulling that into FCPX but can't seem to figure that out either.

Any help you guys could offer would be life saving at this point.

Thanks!


Return to posts index

Mark Spencer
Re: Still can't export with transparent background
on May 2, 2017 at 1:53:59 pm

Kay, I just tested those exact settings and it works perfectly. I exported a ProRes 4444 movie with alpha and imported into FCP X and the alpha channel in intact. Perhaps post screenshots of your canvas in Motion (with the background set to transparent), a shot of your export settings, and a shot of the clip in FCP X connected over a video clip or image so we can see the transparency or lack thereof.
Mark

--
Mark Spencer
Freelance Producer/Editor/Motion Graphics Artist
Apple-certified Master Trainer
Author, Motion 4 from Peachpit Press
http://www.applemotion.net


Return to posts index

Robin S. Kurz
Re: Still can't export with transparent background
on May 3, 2017 at 8:18:10 am

Exactly. When in the canvas hit ⇧T. Do you see a checkerboard pattern where you expect your transparency, a lá Photoshop? If not, then there is something wrong with your project settings, there's a rogue layer or the likes. If you DO see it but aren't getting your alpha with the export settings as described above, then I for one am stumped…

When in doubt, copy/paste everything into a brand new project and check matters there (hitting ⇧T before pasting).

- RK

____________________________________________________
Deutsch? Hier gibt es ein umfassendes FCP X Training für dich!


Return to posts index


Kay Ghey
Re: Still can't export with transparent background
on May 13, 2017 at 10:39:55 am

Hi guys,

Thanks so much for the time and attention. I've still got nothing. At present, here's my canvas and export settings.




Return to posts index

Kay Ghey
Re: Still can't export with transparent background
on May 13, 2017 at 10:45:57 am

And here's the clip imported into FCPX.

I'm just baffled. The alpha layer doesn't seem to show in FCPX and I also have black backgrounding if I open or view it in VLC or quicktime (not sure if that matters.

Thanks for putting eyes on this, guys. I'm pretty well stumped. I keep trying new export settings and just don't seem to have something in the right place.


Return to posts index

Bret Williams
Re: Still can't export with transparent background
on May 14, 2017 at 3:16:12 am

Have you tried it with the premultiply box off? That would be the preferred setting. That would be a straight alpha matte. Also check your project settings in Motion. Isn't there a setting in there to render a solid background o something like that? Not at my computer right now...

_______________________________________________________________________
http://BretFX.com FCP X Plugins & Templates for Editors & Motion Graphics Artists


Return to posts index


Robin S. Kurz
Re: Still can't export with transparent background
on May 14, 2017 at 10:25:13 am
Last Edited By Robin S. Kurz on May 14, 2017 at 10:25:54 am

Actually, there is not globally preferred alpha, be it straight or premultiplied. In the end, if the math is done correctly (i.e. the interpretation is set correctly), then both will deliver perfectly fine results. Some NLE in fact don't even accept or recognize straight alphas, so at least in that context you're safer going matted. But fortunately in the case of FCP it's irrelevant.

So you'll simply want a) check your project settings in Motion as Bret said and make sure the background isn't set to SOLID. Because then you can render all day long with any given setting and you'll never get your alpha.



Then b) check the clip settings IN FCP how the file is being interpreted, i.e. make sure it's set whatever it is you used and not being ignored (which is actually extremely unlikely with a file coming from Motion).



If EVEN THEN it's not working, which would be very odd, then you'd have to post the clip or a frame somewhere so one could have a look.

- RK

____________________________________________________
Deutsch? Hier gibt es ein umfassendes FCP X Training für dich!


Return to posts index

Kay Ghey
Re: Still can't export with transparent background
on May 28, 2017 at 9:15:48 pm

Hey Robin,


If I could ask, where are you checking that box in FCPX that describes alpha handling.

I had to walk off from this project for the last month and I'm just settling back in and still banging on this. I'm sure it's something mundane I'm doing wrong, but I've gone down the checklist and am just still not getting results.

(I'm back on generation in FCPX, but where is that same alpha handling box you screen shotted available in 10.2.3?)

Thanks Robin


Return to posts index

Kay Ghey
Re: Still can't export with transparent background
on May 28, 2017 at 9:25:54 pm

Ok I've discovered that box.
Still jiggering.


Return to posts index


Kay Ghey
Re: Still can't export with transparent background
on May 28, 2017 at 9:56:57 pm

Hi Team,

It's still just not budging for me. I've gone ahead and recorded and uploaded a quick screen cast to see if anyone can spot me making the mistake, located here.







Note, I went back and immediately changed the "Alpha Handling" to "Straight" right after I cut the video.
I feel like I've done everything right and am just not getting it to work...

Thanks guys. you're invaluable.


Return to posts index

Kay Ghey
Re: Still can't export with transparent background
on May 28, 2017 at 10:09:58 pm

Sweet mother of Jehovah...

Alpha channel is non-functional when FCPX display settings are set to "Proxy Media" it would seem...
I think I just figured out where a week of my time went...


Return to posts index

Robin S. Kurz
Re: Still can't export with transparent background
on May 29, 2017 at 7:25:58 am

[Kay Ghey] "I've gone ahead and recorded and uploaded a quick screen cast to see if anyone can spot me making the mistake, located here."

Well, for starters, in that clip you have the render set to ALPHA ONLY and not COLOR + ALPHA. With that, you are rendering only the black and white alpha channel not an RGB clip with alpha channel!


[Kay Ghey] "Alpha channel is non-functional when FCPX display settings are set to "Proxy Media" it would seem..."

THAT of course being the step that makes near every other irrelevant, yes. Proxies are rendered in 422 Proxy. Ergo: no alpha.

But either way, I don't understand why you even insist on RENDERING the clips, when you could simply PUBLISH the project as a generator. In which case there would be zero alpha issues, not even with FCP set to proxy. Not to mention just a fraction of disk space and time required.

- RK

____________________________________________________
Deutsch? Hier gibt es ein umfassendes FCP X Training für dich!


Return to posts index


Kay Ghey
Re: Still can't export with transparent background
on May 30, 2017 at 7:05:20 pm

Hi Robin,

Thanks for sticking with me.
Honest answer to why am I rendering as opposed to publishing? Because I'm stupid ☺

I'm still brand new to motion and simply don't know any better. Thanks for the response, I'm slowly finding my way and your willingness to offer advice to a newb is invaluable.

-Kasey


Return to posts index

Robin S. Kurz
Re: Still can't export with transparent background
on May 31, 2017 at 1:23:23 pm
Last Edited By Robin S. Kurz on May 31, 2017 at 1:24:26 pm

So the entire thing actually came down to your being set to proxies? Or had you been using the same settings as in your video the whole time? Or both? Because both (be it together or by themselves) will of course lead to your issues.

Either way, in the context of using them in FCP, you'll want to publish your projects instead of rendering them 99% of the time, yes.

- RK

____________________________________________________
Deutsch? Hier gibt es ein umfassendes FCP X Training für dich!


Return to posts index

Kay Ghey
Re: Still can't export with transparent background
on May 31, 2017 at 11:48:53 pm

Thanks Robin ☺

But yeah, the greater amount of issues were working with Proxy files. I'm working on a severely underpowered computer right now and so didn't have a lot of options. Upgrading soon.

And thanks again for the advice on publishing as opposed to rendering. I'm learning more about the difference but it does seem to be helping :)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]