FORUMS: list search recent posts

Motion Shadows don't work with reflective stage

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Justin Mrkva
Motion Shadows don't work with reflective stage
on Jan 15, 2013 at 2:47:11 am

I have 3 lights, a text layer, and a reflective stage made of a color solid. Everything works, except the text layer doesn't cast shadows.

Shadows are on for all of the lights, the text layer, and the render.

Any ideas? You can download the example HERE.

Thanks in advance!


Return to posts index

Jason Watson
Re: Motion Shadows don't work with reflective stage
on Jan 15, 2013 at 6:55:38 am

I think it's the image mask that is doing it. When I disabled it the text shadows showed up. I don't exactly know why, but I've noticed that image masks and shadows can be wonky sometimes.

I found two solutions, one of which is much easier.

First, you could clone that text layer, draw a regular mask on it (add blur, animation, etc.) and it will cast shadows.

Secondly, and much easier: check the 'flatten' box in the final_logo Group tab in the Inspector.


Return to posts index

AJ Robinson
Re: Motion Shadows don't work with reflective stage
on Jan 15, 2013 at 2:49:11 pm

Hey Justin!

I had just the problem you had on one of my earlier projects! Here's the problem. Rasterization. You can read more about it here http://help.apple.com/motion/mac/5.0/en/motion/usermanual/#chapter=A%26sect...

So, assuming you read above, you need to make the layer 2D, or flatten it. In the group controls for final_logo, select flatten. This will solve your shadow problem. Now, you have to work the lights somehow so that only one light effects that layer, as the 3 shadows is crazy!
Do you know how to arrange the shadows so only one light is showing?

BTW, NICE animation!

I hope I helped.

~AJ


Return to posts index


Justin Mrkva
Re: Motion Shadows don't work with reflective stage
on Jan 15, 2013 at 4:50:35 pm

Aha. That makes sense, although I wish rasterized 3D objects could cast shadows. I mean, why not? The thing about Flatten is that it causes a loss of 3D perspective, since it treats the layer as a projection from a camera positioned directly in front of it. Something like Flatten With Perspective would be a great option, essentially telling it to Flatten the layer, but using the active camera.

So I thought to use a normal mask, since the image mask apparently is what's causing the rasterization. However, here's the problem with a "normal" mask - that text layer is really a placeholder for a 3D group that I have in my real project. AFAIK (and I tried) you can't apply a bezier mask to a 3D group, only an image mask. If I convert to 2D I lose the effect. That said, I'm not even sure if a bezier mask would cause rasterization; it might, given the 3D perspective involved.

However, I figured the whole thing out, INCLUDING the layering issue I had with the overlay cutting off on the floor (mentioned in another thread).

Here's the layer structure I ended up using:

Logo Group
----Flat Logo (clone layer)
----Replicator (for 3D effect)
--------Flat Logo (replicator cell)
----Flat Logo
--------Image Mask
--------PSD file
--------Misc. layers

First of all, I can't apply Flatten to the Logo Group because it destroys the 3D effect generated by the Replicator. Because of the way they're stacked, though, I could apply the Image Mask to the Flat Logo group and flatten only that layer. Then, the Replicator is set to use Flat Logo, and the Clone Layer is also set to use that group as well. Shadows are cast only from the clone layer, since casting multiple shadows from all the replicator cells doesn't look very different and slows down the render... a lot. :D The end result is essentially the same visually as applying the Image Mask to the Logo Group, but allows me to Flatten the Flat Logo group, eliminating the rasterization that comes from the Image Mask.

Secondly, in using the Flatten option, I discovered another option - Layer Order. In another question, I had a floor and a 3D positioned layer that was getting cut off by the floor but that I didn't want cut off; I wanted it to appear on top, rather than obeying layer positioning and clipping. Layer Order does just that. Incidentally, the same Image Mask bug that was causing shadows to fail was also causing that layer to appear on top before, something I was exploiting to get it to appear how I wanted, so finding the Layer Order option really saves me here as well.

Also, yes, 3 shadows is a lot, I hadn't softened them yet. I can't reveal much about the project at this time, but I can give you a small screenshot that shows what the shadows look like in the final comp:



Thanks for the help! :)


Return to posts index

AJ Robinson
Re: Motion Shadows don't work with reflective stage
on Jan 15, 2013 at 5:30:23 pm

Yep! Rasterization really messing things up! I didn't know that you had a 3D replicator on the text. In the project you uploaded there was no replicator. Hey, if you still want that shadow, just duplicate the text layer, angle it 90 degrees, color it black, set the opacity to 50, and place it on the floor & enjoy animating! There ya go!
Flatten just screws the whole 3D up. Well, you have fun with the project!

~AJ


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]