FORUMS: list search recent posts

Phantom Rigs...

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Wayne Williams
Phantom Rigs...
on Nov 18, 2011 at 8:40:35 am

I am having a problem where a parameter previously assigned to a Rig show as assigned even though I have deleted all rigs from my project. Issue is that I cannot reassign that parameter for a given layer to a new Rig. Is anyone else experiencing this problem?

thanks,

Wayne


Return to posts index

Mark Spencer
Re: Phantom Rigs...
on Nov 18, 2011 at 2:01:19 pm

Yes that happens all the time. No way to get rid of it that I know of.

--
Mark Spencer
Freelance Producer/Editor/Motion Graphics Artist
Apple-certified Master Trainer
Author, Motion 4 from Peachpit Press
http://www.applemotion.net


Return to posts index

Brendan Gibbons
Re: Phantom Rigs...
on Nov 18, 2011 at 8:07:39 pm

Yes that problem can be very annoying.

The only way I have found around it is to remove the parameter from the rig before deleting the rig.

I know that doesn't really help you at the moment but it's the way I do things now after getting trapped with this problem a few times.

Cheers,

BG


Return to posts index


Scott Barnes
Re: Phantom Rigs...
on Sep 28, 2013 at 6:15:41 am

I wanted to offer up a solution for this bug as it happened for me today. First this is not for the faint of heart, so backup before you start and in a lot of cases it could just be easier to delete the object and redo it. In my case I had a lot of other rigging already done to different parameters on the same element and I would have basically had to start over. So I opened up the .motn file in a text editor (I used TextWrangler) apparently its just one great big xml document. So I searched for "Rig Behav". This will jump you from one Rigged Behavior to the next but if you should be able to figure out what object it is applied to by following it up the tree up as well as what type of parameter your wanting un-rig. So mine was a rotation so when I ignored any Rigged parameters that were position or birthrate or anything else but rotation. Then I deleted everything in-between the <behavior> </behavior> tags. This worked for me and might help others out.

I am not bound by what is possible.


Return to posts index

Lance Erickson
Re: Phantom Rigs...
on Nov 13, 2013 at 12:58:23 am

Thank you Scott. Worked for me using TextEdit.


Return to posts index

Mark Spencer
Re: Phantom Rigs...
on Nov 13, 2013 at 1:13:12 am

Great solution Scott.

--
Mark Spencer
Freelance Producer/Editor/Motion Graphics Artist
Apple-certified Master Trainer
Author, Motion 4 from Peachpit Press
http://www.applemotion.net


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]