FORUMS: list search recent posts

3D Particles Not Using Depth Order

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jimmylee Remillard
3D Particles Not Using Depth Order
on Dec 17, 2010 at 11:09:12 pm

Hey, i'm making a tutorial on particle glows and I ran into a problem that had not come up when I created this the first time.

My particles seem to be following the layer based priority rather than the Z space priority, meaning, I put some text in my project then put some particles and all of the particles are floating infront of the text even if they are behind it in z space.

I made sure its a 3D layer, it has Depth Ordered checked, its on Global 3D and none of my other groups have Layer Order checked.

Like I said, i've done this project before and this did not happen... this is just one of the many bumps I came into while recreating my OWN project. There is always a problem in motion, things just dont like to work the way you would think they should.

thanks for the help,
Jimmylee


Return to posts index

Mark Spencer
Re: 3D Particles Not Using Depth Order
on Dec 17, 2010 at 11:12:22 pm

You probably did something to cause your group(s) to become rasterized - you can tell because the icon for the group changes from a stack of three rectangles to the same stack but with a box around it. Things that can cause rasterization (or "precomping") including changing opacity of a group, changing the blend mode, or certain filters applied to the group. Look in the Properties Inspector with the rasterized group selected - the offending parameter will have a blue led light next to it.

--
Mark Spencer
Freelance Producer/Editor/Motion Graphics Artist
Apple-certified Master Trainer
Author, Motion 4 from Peachpit Press
http://www.applemotion.net


Return to posts index

Jimmylee Remillard
Re: 3D Particles Not Using Depth Order
on Dec 18, 2010 at 12:42:38 am

Thanks Mark, so what was doing it was the Light Rays filter. It's weird because I used the exact same effect before and it didn't not do this.. oh well, ill just have to work around it thanks.

Just so its clear, the reason is because the light rays filter changes my blend mode from passthrough to normal and also not making pass through available... thanks.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]