FORUMS: list search recent posts

Motion only using 1 processor?

COW Forums : Apple Motion

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Job van Nuenen
Motion only using 1 processor?
on Jul 11, 2007 at 9:05:34 am

Hi there,

I'm setting up an animated 'watersplash' consisting of an explosion 4000 initial particles and loads (900deg.) of motionblur.

I'd expect Motion to get a little slow on this. but the rendertime I get for this on a 2x3GHz Quad-core with 8Gb seems absurd to me: 4,5 hours for 8secs of animation.

When I opened up the activity monitor it showed that Motion is only using 1 out of 8(!) processors at a time. In preview mode I can understand this, thinking in terms of communication with GPU and stuff, but at rendertime I'd really like to see those 8 bars get maxed out..

Anyone had this experience? or am I overseeing something? (ps. the app isn't by mistake running under Rosetta)

Graphics card is a RadeonX1900-512Mb

thanx!

Job


Return to posts index

Zak Mussig
Re: Motion only using 1 processor?
on Jul 11, 2007 at 4:02:29 pm

Are you exporting directly from within Motion or using the "Export using Compressor" option? I would imagine going the Compressor route would use all of your processors, assuming your machine is set up with multiple instances of Compressor.

If it isn't, check page 49 of the "Distributed Processing Setup" doc, which can be found under Compressor's Help menu.

Hope that hels,
Zak


Return to posts index

Noah Kadner
Re: Motion only using 1 processor?
on Jul 11, 2007 at 4:04:07 pm

What version of Motion?

Noah

Unlock the secrets of the DVX100 and Final Cut Pro!
http://www.callboxlive.com


Return to posts index


Job van Nuenen
Re: Motion only using 1 processor?
on Jul 11, 2007 at 5:16:05 pm

I'm using Motion 3. And I'm rendering direct with the 'Export from motion command', since I'm only exporting Animation compressed b/w mattes to AFX.

FCP shows nicely waving green bars at all processors, when rendering. So i tried placing my Motion project in a FCP timeline and render from there. Funny thing: first thing in the timeline is a simple slomo effect from FCP: all processors work. As soon as it starts rendering the MotionProject part: boom only one processor, completely maxed out.

Looks like I'm missing the 'use all processors for Motion too' button somewhere.

I'll try the --Export via compressor-- tip, but it seems to me that the processing of the 'real' pixeldata probably still will be handled by one proc, while the encodingpass that compressor puts on it will be handled by multiproc.

I'll keep you posted, thanx so far.

Job


Return to posts index

Job van Nuenen
Re: Motion only using 1 processor?
on Jul 11, 2007 at 5:32:35 pm

Hi again, tried activating the processors for Compressor in Qmanager. This doesn't have any effect on the render. still only 1 processor that's working really well..

For now it's just a matter of patience I think..

thanks though :)

Job



Return to posts index

adrian charles
Re: Motion only using 1 processor?
on Jul 11, 2007 at 8:04:45 pm

Job,

if you look at bare feats http://barefeats.com/rosa04.html. it does state that this is an issue!

hope the link helps

Adrian Charles


Return to posts index


Job van Nuenen
Re: Motion only using 1 processor?
on Jul 12, 2007 at 6:09:33 am

Hi Adrian, thanx! That's a disturbing message there, to say the least.. It feels odd, having all this processorpower built into your new product and at the same time, having your most processor-intensive app not up to speed to cope with all this power.

It's like designing a muscle car but mounting the accelerator pedal in a such a position that it only goes halfway (or 1/8th way, to exact).

I guess it "hoping for updates - time" again then. I guess motion 3.2 will be an update that will blow us all away...

come think of it.. On all those demo's I've seen Motion running like clockwork, even in HD, that might just be special Demo versions that DO use all the processors :) I'm sure I'll be checking the processor stats on the Apple-stand at the next IBC conference..

Anyone else has an idea about this?

J


Return to posts index

adrian charles
Re: Motion only using 1 processor?
on Jul 11, 2007 at 8:15:20 pm

job,

that link should read http://barefeats.com/rosa04.html

sorry

Adrian Charles


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]