FORUMS: list search recent posts

Blend & Comp Blend Modes

COW Forums : Autodesk Smoke

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Daniel Burrell
Blend & Comp Blend Modes
on Jun 16, 2014 at 9:45:47 pm

I am working on a video where I need to use SD footage in a HD timeline. I'm trying to do what you typically see on the news, where the 4x3 footage is blown up to fill the screen, and then a copy of that footage is placed behind it, blown up more, and blurred, and that fills in the rest of the width of the screen. I thoguht I could just take my source, do a 2d Transform, and take that into the blend & comp, as well as using that same input to transform and blur for my back footage. But, when I do that, no matter what blend mode I select, my front picture is always partially transparent. Maybe this should be done in action instead, i'm not sure, but it seemed like the method I'm using should work, it just isn't. I've attached a picture of my schematic and result. If I select the "Blend" blend mode, I can only see the front picture with black bars on the sides.



Return to posts index

Grant Kay
Re: Blend & Comp Blend Modes
on Jun 17, 2014 at 8:02:19 am

Hi Daniel,

Having a close look at your schematic, the first issue I see is that you do not have a solid matte/alpha for your footage. You are feeding the image as the matte. So when the blend and comp performs the blend operation, it is basically using the luminance from your SD footage and keying it over the fill. Hence you get the luminescent composite.

The way to do this correctly is to use a colour frame node that matches the resolution of your SD material. This should be fed into your matte channels and this will give you a solid matte and this won't happen.

I recreated this on my machine and I am attaching a screenshot of what I did.

I hope this makes sense.

Regards
Grant



Check out the Smoke Learning Channel

Youtube - http://www.youtube.com/smokehowtos
or search for the Smoke Learning Channel on iTunes
Follow me on twitter @discreetuk


Return to posts index

Daniel Burrell
Re: Blend & Comp Blend Modes
on Jun 23, 2014 at 1:11:58 pm

When I do that, I get a red dot on the resize node, and nothing coming through. Here's a screenshot of my schematic



Any idea what I need to do to fix this?


Return to posts index


moody glasgow
Re: Blend & Comp Blend Modes
on Jun 23, 2014 at 4:21:04 pm

The red dot usually means you inputs with different resolutions. Just copy the resize node, and feed you colour solid into it, then out to the matte input on the 2d transform.

moody glasgow
smoke/flame
http://www.thereelthinginc.com


Return to posts index

Daniel Burrell
Re: Blend & Comp Blend Modes
on Jun 23, 2014 at 4:37:28 pm

One more question. I started this over from scratch, and my destination is 720x480, but I need it to be 1920x1080. How do I change the size of the CFX Output?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]