FORUMS: list search recent posts

Trouble with PSD, trying to do paralax effect

COW Forums : Autodesk Smoke

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Daniel Burrell
Trouble with PSD, trying to do paralax effect
on Jun 13, 2014 at 8:44:57 pm

I am trying to do a paralax effect with a picture. I have gone into photoshop and cut out layers of the photo, and saved the file as a PSD file, no special settings. When I bring it into Smoke, I can bring it in with separate alpha channels, or with a matte container, where it brings in each layer, but no alpha channels. No matter what I do, it seems that when I go into connectFX and drop in my layers and try to bring them into action, there is no transparency. When I select an image and look at the interface at the bottom, it shows the picture, and then below that it says "Matte Off". What do I need to do to get the mattes coming through so I can work with these as separate layers in 3d space?


Return to posts index

Brian Mulligan
Re: Trouble with PSD, trying to do paralax effect
on Jun 13, 2014 at 9:25:49 pm

Your PSD layers need to be rasterized in PS. So each layer needs to be flattened with it's cut out matte.

Then in Action .. use the import node, while looking at your empty schematic and IMPORT your PSD. All the layers will import as a comp and then you can just adjust Z depth.

turn on the option on the AXIS to adjust the size on all transforms so your comp doesn't change visually towards the camera but still moves the layer in Z space.

Brian Mulligan
Senior Editor - Autodesk Smoke
WTHR-TV Indianapolis,IN, USA
Twitter: @bkmeditor


Return to posts index

Daniel Burrell
Re: Trouble with PSD, trying to do paralax effect
on Jun 13, 2014 at 9:49:43 pm

I hate asking this, but i'm having trouble in photoshop rasterizing the layers. I don't have an option to rasterize the layers, (it's greyed out) and I can only flatten the entire image. I have the picture cut into 4 layers, and those are the only 4 layers that I have in the project right now. I know i'm missing something, I just don't know what it is.


Return to posts index


Daniel Burrell
Re: Trouble with PSD, trying to do paralax effect
on Jun 13, 2014 at 9:55:38 pm

If I go in and make the layers smart objects, I can then rasterize the layers individually, is that what I am supposed to do?


Return to posts index

Brian Mulligan
Re: Trouble with PSD, trying to do paralax effect
on Jun 13, 2014 at 10:00:16 pm

Can you email the psd to bkm.editor at gmail.com?
In PS
You can add a blank layer above a layer then select both and then flatten. Repeat for each layer.

Brian Mulligan
Senior Editor - Autodesk Smoke
WTHR-TV Indianapolis,IN, USA
Twitter: @bkmeditor


Return to posts index

Brian Mulligan
Re: Trouble with PSD, trying to do paralax effect
on Jun 13, 2014 at 10:01:57 pm

Yes that will work.

Brian Mulligan
Senior Editor - Autodesk Smoke
WTHR-TV Indianapolis,IN, USA
Twitter: @bkmeditor


Return to posts index


Daniel Burrell
Re: Trouble with PSD, trying to do paralax effect
on Jun 13, 2014 at 10:07:29 pm

Cool, and in your previous instructions, when you said flatten, I don't have an option to flatten, but I do have an option to merge layers, is that correct?


Return to posts index

Brian Mulligan
Re: Trouble with PSD, trying to do paralax effect
on Jun 13, 2014 at 10:06:39 pm

Also see this. ..https://www.google.com/url?sa=t&source=web&rct=j&ei=ynWbU-zzCISlyAT8l4KwCA&...

Brian Mulligan
Senior Editor - Autodesk Smoke
WTHR-TV Indianapolis,IN, USA
Twitter: @bkmeditor


Return to posts index

Daniel Burrell
Re: Trouble with PSD, trying to do paralax effect
on Jun 16, 2014 at 1:47:09 pm

Okay, that all worked and I have everything in place and animated, but when I blur the foreground, the layer hits the edge of the raster, so it cuts off the top of the person's head that's standing in the foreground. Brian, you've helped me with this before, Usually to fix this I go in to ConnectFX and do a 2d transform before action, but I imported directly into action and I don't have the option of doing that in ConnectFX because I can't see my individual sources in ConnectFX, only in Action. So how would I go about fixing this problem in action, or in photoshop before I export?


Return to posts index


Brian Mulligan
Re: Trouble with PSD, trying to do paralax effect
on Jun 16, 2014 at 1:59:32 pm

2 ways...

1 select you media in the media list-in Action.
press EXTRACT next to it on the left. It will pop this out in CFX.
You can add a 2D transform there.

2. In Action Pull up a SOURCE FRONT and SOURCE MATTE.. mimic link the axis together. (shift w I think) then you can scale back the media within the raster.

Brian Mulligan
Senior Editor - Autodesk Smoke
WTHR-TV Indianapolis,IN, USA
Twitter: @bkmeditor


Return to posts index

Daniel Burrell
Re: Trouble with PSD, trying to do paralax effect
on Jun 16, 2014 at 2:52:47 pm

I had tried the method from within action before and couldn't get it to work. I wasn't able to pull up the matte by itself, any time I tried to do it, it just pulled up the front. But, I did find a workaround in photoshop. I just drew a line at the top of the photo and merged that with the layer that was cutting off. The line is outside of the area that I am using, so it will be cropped out, but when it exports it keeps the matte on the entire frame.


Return to posts index

Leo Mendoza
Re: Trouble with PSD, trying to do paralax effect
on Apr 18, 2015 at 5:53:36 pm

Hi Guys,

I want to do a composite using PSD files... as to preserve all the blend modes, axis and positions...
My question is how do i cache PSD files inside Flame after using the import node inside the Action? Because when I import my PSD file, I assume it is directly linked to its external drive, and not cached in.

Why am I asking this... there was this incident. Ive done all my animations and stuff, happy then saved my batch. And after less than 5 minues, I needed to revise something, I opened my batch and BOOM! all the layers turned red, all layers are missing clips.

Do you have any encounter of this?
Is this more of a caching issue?

LEO
I like the idea of importing PSD directly to action, but it doesn't seem stable after this incident... it didnt happen once but twice on two different PSD files already.

Need help on this, thanks!!!


Return to posts index


Grant Kay
Re: Trouble with PSD, trying to do paralax effect
on Apr 20, 2015 at 9:40:43 am

After the PSD file is imported into Action, you can expand the images out into Batch.

They should appear in the Media Panel and you can right-click and cache the sources.

Alternatively you you expand the images out into Batch. Than you would go through each one by selecting the clip, creating a BFX/CFX clip and rendering it. This is a manual way to do it but it should leave you with a rendered version in the Media Folder.

Hope this helps.

Regards
Grant

Check out the Smoke Learning Channel

Youtube - http://www.youtube.com/smokehowtos
or search for the Smoke Learning Channel on iTunes
Follow me on twitter @discreetuk


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]