FORUMS: list search recent posts

Bizarre looping

COW Forums : Adobe Encore DVD

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Joseph Owens
Bizarre looping
on Mar 11, 2015 at 2:32:56 am

Creating a DVD under CS5, and also tried creating a version in CS6. Same behaviour:

We want to play a 20 second "WARNING" as First Play, so I made a graphic, fadeup/fadedown, compressed an m2v of it, and even a silent ac3, and a timeline. From there, we want to go to a Main Menu with a couple of buttons... the usual, Play, Special Features, Chapters... The concept is to have a Quicktime running behind it with natural sound, so we have a 28 second menu, set up to play #infinite, loop point 00:00:00:00 and a duration of 28 seconds.

What is confounding is that this functions exactly as advertised in the Encore simulator, and on consumer DVD players... but NOT on any PC, Apple or Windows, either the Apple DVD PLayer or Windows Media Player. What the physical disk does is -- play the Warning, which is great.. switches to the Main Menu, plays it once and quits. No more anything. Black. Operation Not Available.

What is also galling is that if you do not allow the main menu to play all the way to its 28 second conclusion, the disk functions normally, even when you return either with a "Back" button from a discrete "Main Menu" command found on any other menu -- it loops forever over its 28 second duration...

What the....?

jPo

"I always pass on free advice -- its never of any use to me" Oscar Wilde.


Return to posts index

Joseph Owens
Re: Bizarre looping
on Mar 12, 2015 at 3:29:17 pm

So... couple of observations...

Either not a lot of people are using Encore.
Or... not a lot of traffic in this forum...
or nobody has any ideas...
or...?

But just in case some wandering soul finds this thread (probably by mistake), a couple of days of feverish net-mining started yielding some clues -- none of which directly solved the problem.

Worthwhile advice was found in "flush the media cache"... which changed the behaviour of the Encore preview player. It started crashing at the end of the "Main Menu" first loop and coughed up a "General Error." Maybe some tiny lightbulbs for some people, but frankly this kind of error dialogue is just an insult to the world.

None of the usual suspects, cited over and over as the problem, for example, a bad End Action, or a lingering or poorly threaded "Override" were to blame. Mis-matched audio and video backgrounds weren't it, either. But when I hit the "General Error," finally, those with long experience with Final Cut might start thinking.... hmmmm... what was the issue the software developers were concealing and couldn't figure out how to cope with...

I re-routed the navigation at one point to one of the other menus in the subsidiary trees, and maybe not surprisingly, the looping functioned properly with that... but not really the path we wanted our viewers to take.

With that, I started re-examining all the elements in that menu. Interestingly enough, for someone who is easily amused, I started wondering about the combinations of 720x480, 853x480 (which would ordinarily be what you wanted for a graphic 16x9 element) and anamorphousness, if that's a word.

So I went back to the background video element, which was a down-rez from an HD 1920x1080 23.98P original, and popped it into a Final Cut timeline to see what the Sequence-matcher dialog would say. Even though it was nominally ProRes422(HQ), FCP identified it as DVCPro. Probably something to do with the fact that it had been supplied to me as 853x480. Those in the know will start nodding sagely and say, hmmm... yesssss... ProRes doesn't like being asked to accommodate non-orthodox resolutions.

That wasn't it, either. Well, not completely.

Completely deleted everything in the project related to that menu. Shut down.

Opened up the supplied elements and duplicated them, recompressing all, including the .psd overlay.

Opened Encore, built the menu from scratch, left everything in default, routed the buttons, created a clickable area for each of the buttons so users didn't have to play mumbly-peg with the tiny text icons, Preview...

And it worked. Why? I have no idea.

jPo

"I always pass on free advice -- its never of any use to me" Oscar Wilde.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]