FORUMS: list search recent posts

Adobe Encore and forced transcoding

COW Forums : Adobe Encore DVD

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Juan Torres
Adobe Encore and forced transcoding
on Dec 8, 2009 at 11:11:34 pm

Hello mates,

I'm encoding with AviSynth + CCE-SP2, using original fps (23.976 or 25) as output's frame rate, and then flagging up to 29.97 fps with DGPulldown, but then when importing to Adobe Encore CS4 a transcode is forced, there's no [i]Don't Transcode[/i] option... is someone familiar with this problem?
I'm pretty sure my files are 100% DVD compliant: I can author with DVD-lab and everything is fine, the DVD is playable and all.

Take into account this:

1. Frame rate IS the problem. I encoded again, this time using 29.97 as output (source was 23.976), and Encore finally accepted it as DVD compliant! (no forced transcoding) So, apparently Encore doesn't like pulldown flags...

2. I've encoded using original frame rate (23.976) and then applied pulldown flags with DGPulldown, pulldown.exe, CCE's pulldown, DVD-lab's pulldown... and Encore ALWAYS wants to transcode my video.

3. ONLY if I choose 29.97 as output's frame rate in CCE then Encore decides not to transcode. It's like Encore saying "that's right, pulldown flags aren't allowed, only true 29.97 fps".

4. When applying pulldown the output is reported as 29.97 fps (pulldown.exe) or 23.976 fps with 2:3 Pulldown (DGPulldown) and Encore STILL wants to transcode it!

5. I've even used DVDPatcher to change the MPEG's header (both [i]first header only[/i] and [i]entire file[/i]) and results are the same.

Seriously, what am I doing wrong? I think I'm going mad...
Right now my only workaround would be to encode directly to 29.97, however, as input and output frame rates would differ, frame insertion or frame skip would occur.. and that's not what I want.

Thanks.


Return to posts index

Juan Torres
Re: Adobe Encore and forced transcoding
on Dec 9, 2009 at 10:26:53 pm

Just to let you all know, here's the solution:

GOP length... it was 15 frames, which with pulldown applied it would result in at least 19 frames (NTSC DVDs should be 18 frames max)
So, frame rate was related to the problem, it just wasn't THE problem.

Anyway, in CCE-SP2's MPEG Video Settings (Advanced settings) I just changed the N/M value from 5 to 4. Now output's GOP length is 12 frames ;)

Honestly, if Adobe Encore is targeted at professional video producers it should at least throw a warning message saying "GOP length is too high" or similar...


Return to posts index

eric pautsch
Re: Adobe Encore and forced transcoding
on Dec 9, 2009 at 10:44:34 pm

I wouldn't consider Encore a professional DVD tool but I'm glad it worked.



Return to posts index


Juan Torres
Re: Adobe Encore and forced transcoding
on Dec 9, 2009 at 10:48:22 pm

Hello Erich,

What do you consider a professional DVD tool? I was about to start using Encore as my main DVD author, maybe I should skip it and check out whatever you recommend.


Return to posts index

eric pautsch
Re: Adobe Encore and forced transcoding
on Dec 10, 2009 at 4:23:32 am

Either DVDSP or DVDLab if you're on a budget. Scenarist if you plan on doing alot of work. I think its down to $5K now. Off the top of my head, Encore has tons of bugs and it provides no scripting capabilities.



Return to posts index

Juan Torres
Re: Adobe Encore and forced transcoding
on Dec 10, 2009 at 7:29:46 am

I have always used DVD-lab PRO for authoring. I recently tried Encore for it's great Photoshop integration and the export as DVD/Blu-ray/Flash feature; you know, trying it myself to see if it really is as good as some people say, or as bad as others claim.

Besides, I don't know if it's a DVD-lab issue, but my subtitles ALWAYS show earlier, no matter which timecode option I choose (and yes, I'm sure that they are correctly in sync with the video before authoring) Also, when I import subs they don't preserve italics, very annoying. I'm doing the same project in Encore to see if subs are properly synced this time.

Now that I think about it... maybe subs have always showed earlier because till now (changing N/M value in CCE from 5 to 4, thus, GOP length of 12 frames instead of 15) my files never had the correct GOP length and timecode was all messed up. I will do some testing later.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]