FORUMS: list search recent posts

Don't Transcode Transitions

COW Forums : Adobe Encore DVD

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Timoto
Don't Transcode Transitions
on Jul 27, 2006 at 10:32:59 am

Using Encore 2.0 I have a project that has many MPEG2 compliant streams imported. "Don't Transcode" appears next to these assets, great that's what I want. However if I decide to select one of those assets a Transition between menus Encore decides it needs to trancode the asset. Annoying.

The transition files are very short, say 4 seconds duration. These files playback fine in say Nero Showtime, but when imported into Encore and played there are some very spurious artifacts appearing in the image, even whole screen colour changes or RED or Black. If I then allow Encore to Transcode these MPEG2 files the outcome remains spurious. My workaround is to import the original D1 data and allow Encore to transcode that instead.

I would still like to know why this bug exists.

1. Encore should not Transcode the already compliant MPEG2 file.
2. It should not interpret the footage with lots of garbage artefacts.


http://www.globaltimoto.com


Return to posts index

Jeff Bellune
Re: Don't Transcode Transitions
on Jul 27, 2006 at 5:26:08 pm

How were the files originally transcoded? What software and what settings?

-Jeff

The Focal Easy Guide to Adobe Encore DVD 2.0


Return to posts index

Timoto
Re: Don't Transcode Transitions
on Jul 28, 2006 at 1:11:14 pm

Hi Jeff

I'm using Caopus Procoder 2.0

I use a standard setting to ensure DVD compatibility. So far I have seen that all my trancodes for movies, video backgrounds work fine and are recognised by Encore as such since it automatically sets the transcode setting to "Don't Transcode" when I import the assets.

The main difference I see is that all these transition sequences are short such as 1 to 4 seconds long.

Sometimes, but not always, when I actually build the DVD these transition sequences do actually render out correctly. In most cases however they don't.

I think that there are 2 bugs

1. Encore has problems with very short MPEG2 sequences.
2. Even though Encore lists the assets as "Don't Trancode" is still transcodes them because they have been used in the project as Transitions between menus.



http://www.globaltimoto.com


Return to posts index


Jeff Bellune
Re: Don't Transcode Transitions
on Jul 28, 2006 at 2:17:09 pm

Encore does have a problem with short timelines. If you need to use a very short asset as a transition in Encore 2.0, use Button Transitions. Check the Properties panel for a menu button and under the Transition tab, link to an asset (not a timeline) in the Project panel. You can use assets shorter than 1 second if you want. This is the proper method and superior to trying to use short timelines for transitions.

Encore 2.0 adds a hidden chapter marker at the end of each timeline. Since chapter markers have to go on GOP boundaries, it's possible that short timelines may trigger a re-transcode. That E2 adds the hidden chapter is a certainty; its affect on re-transcoding is my guess.

-Jeff

The Focal Easy Guide to Adobe Encore DVD 2.0


Return to posts index

Timoto
Re: Don't Transcode Transitions
on Jul 29, 2006 at 1:33:08 pm

Hello Jeff

Actually I am already employing the method of linking to my transition assets from the menu buttons just as you described. I'm not using timelines to do this.

So the question remains:

1. Why does Encore transcode a menu button transition asset that is labeled as "Don't Trancode"?

2. Why do these shorter MPEG files seem to display incorectly after they are imported and played back in Encore?



http://www.globaltimoto.com


Return to posts index

Jeff Bellune
Re: Don't Transcode Transitions
on Jul 29, 2006 at 3:14:07 pm

This Adobe Forum post may help.

I'd focus on your video card drivers and your hardware video acceleration settings to solve the red/black frame problem. Encore 2.0 has PPro 2.0's playback engine, so if you have PPro 2.0 you can also test the mpegs there.

The "don't transcode" solution might be to ensure that Encore's mpeg decoder (from MainConcept) has the highest system priority. If it doesn't, then there might be a disconnect between what the software thinks should be done (don't transcode) and what it can actually do when it's expected decoder isn't available (re-transcode).

I'll see if I can dig up the method for checking on the decoder priority. I think the way to reset it is to uninstall/reinstall Encore.

-Jeff

The Focal Easy Guide to Adobe Encore DVD 2.0


Return to posts index


Jeff Bellune
Re: Don't Transcode Transitions
on Jul 29, 2006 at 4:39:55 pm

Find graphedit at videotools.com, install it and render an .mpg or .m2v file from File>Render a Media File. In the graph window see which video decoder is used to decode the video and send it to the default video renderer.

If it's not MainConcept, you can go to Graph>Load Filter and expand the DirectShow entry. Find the filter that matches the name of the one your system uses to decode mpeg video. Expand that entry. Go to where that file is and rename it .old.

Then preview your red/black problem video clips in Encore. Do they work better?

Depending on your needs and any complaints from your other applications, you can either leave the old decoder renamed or go ahead and name it back.

-Jeff

The Focal Easy Guide to Adobe Encore DVD 2.0


Return to posts index

Timoto
Re: Don't Transcode Transitions
on Jul 31, 2006 at 11:36:18 am

Thank you Jeff for such an accurate response.

First off I used Graphedit to load one of the MPEG files to find that my default decoder was not Main Concept.

So I renamed the decoder with .old extension and loaded up Encore.

The MPEG file loaded and played back fine which it had not done before. Hooray!

I checked with Graphedit again to see that Main Concept was now my default decoder.

I then proceeded to check all my other little transition files in Encore. All but 2 were playing back as expected.

I re-transcoded the 2 suspect files and when I played them back in Encore I noted that the graphic corruption was still there, but slightly different this time. I could see that some of the image was in fact footage from another file all together!

So it looks to me as if there is an error in the way that memory is being used by Canopus, or that the gfx drivers are too old to support the compatibility, otherwise how could this data end up in my Mpeg file?

Unfortunately I use a laptop since I edit my work on the move, which is fine except that when it comes to getting updated graphics drivers there is an extra complication. I have an "Nvidia GeForce4 MX 440 Go" chipset which Nvidia do not support completely in their regular updates. I have to go to my computer's manufacturer. who it seems, can not be bothered to update the drivers with the correct support for the screen resolution of my laptop accordingly. The last time they
did update them was about 2 years ago!

Have you had any experience in this symptom too?

Tim


http://www.globaltimoto.com


Return to posts index

Jeff Bellune
Re: Don't Transcode Transitions
on Jul 31, 2006 at 12:58:56 pm

I'm glad you're making progress!

[Timoto] "Have you had any experience in this symptom too?"

My laptop is 3 years old, and the graphics drivers two, so I know what you're talking about. However, I have never experienced the symptoms that you are. All of my answers derive from my research and from very helpful info given to me by others who were quite generous with their time.

All I can suggest at this point is to try something other than Canopus. MainConcept makes a very good stand-alone MPEG Encoder at a very reasonable price. They have a fully functional demo for you to try. A watermark will be added to your output, but you will at least be able to test whether the encoder works with your files or not.

-Jeff

The Focal Easy Guide to Adobe Encore DVD 2.0


Return to posts index


Timoto
Re: Don't Transcode Transitions
on Aug 1, 2006 at 10:57:36 am

Whoops I got my logic wrong in the last message.

I still have spurious corruption in the playback of some files in Encore.

This has nothing to do with Canopus since playback of these files is perfect in Nero Showtime and other players.

The corruption appears in Encore with some short MPEG files which I use for menu transitions and now I have noticed that a couple of my video buttons are also adding the odd bit of corruption.

If I monitor my movie timelines I see that they too have some of this corruption, however when I build the DVD project the movies play fine, the transitions and video menu buttons still include the corruption.

Something tells me Encore makes some sort of proxy interpretation of footage when imported which is including all sorts of data, sometimes from completely different footage. Is encore somehow not able to manage the data because of old Nvidia drivers or is it just Encore's problem. Could it even have something to do with physical memory?

Tim

http://www.globaltimoto.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]