FORUMS: list search recent posts

CS5: Hyperlink doesn't work

COW Forums : Adobe InDesign

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Rob Hruska
CS5: Hyperlink doesn't work
on May 4, 2011 at 5:21:50 pm

Here is my problem. It's driving me up the wall.

I have an InDesign document with hyperlinks in it that I export to PDF. All of the links work except one.

1. If the text of a link is the same as the URL, it will work. That is, if the text is http://www.creativecow.com and the URL is http://www.creativecow.com, the link will work.

2. If the text is an e-mail address (bessie@creativecow.com) and the URL is a mailto: to that address (like mailto:bessie@creativecow.com), it works.

However, if the text is not the URL (say the text is "CreativeCow Link", no matter what, the link won't work.

To create the link I do the following:

1. Select the text
2. In the Hyperlink panel, click "Create new hyperlink" button at the bottom.
3. Choose "URL" from the dropdown list and paste the URL into the "URL:" field.
4. Whether "Shared Hyperlink Destination" is clicked or not, it doesn't change anything.

If you select the text in InDesign, the link is highlighted in the Hyperlink panel, so InDesign knows it is supposed to be a link. The link does not work in an exported PDF.

Additionally on a semi-related note, I cannot post this to the Adobe forums. Apparently I have to register the software to be able to post, and since I have a volume license I cannot register it, so I cannot post to their forums. Thanks Adobe.


Return to posts index

Nancy Siegel
Re: CS5: Hyperlink doesn't work
on Sep 14, 2012 at 3:06:43 pm

Rob, I am having the same problem. Did you find a solution?

Nancy


Return to posts index

Susanne Murtha
Re: CS5: Hyperlink doesn't work
on Sep 14, 2012 at 8:33:57 pm

I've been working at this for hours and having the same issue. In most instances the text is other than the URL but in one instance it is the same but still doesn't work.

I've also tried checking and unchecking the shared box. I've deleted the hyperlink and put them in again in different ways with no success.


Return to posts index


Chiali Tsai
Re: CS5: Hyperlink doesn't work
on Jan 7, 2013 at 4:01:21 pm

Hi,
Hope you guys already found the solution, :D
here is what I did and it works.

first, you draw a rectangle frame on whatever the text is and convert to a button
2nd, add your action "go to url" and enter your link in the button panel ( and this stage, it wont work)
3rd, go to your hyberlink panel and add new destination, enter the same link as you add on this button
then it should work.


Return to posts index

Andrew Seles
Re: CS5: Hyperlink doesn't work
on Jul 8, 2013 at 5:40:20 pm

I was experiencing the same problem and found that exporting as an interactive PDF resolved the issue (File > Export > Format: Interactive PDF).

Requires tweaking the export settings if you're trying to match High Quality Print profile. Really odd that mailto links and full URLs work using regular PDF presets.


Return to posts index

Jackie Watanabe
Re: CS5: Hyperlink doesn't work
on Oct 14, 2015 at 5:24:12 am

I was having the same issue and then I tried this:

You can save as a PDF (interactive) like another poster mentioned. However, I noticed I would lose a lot of quality in any images in my document. Instead, when you save as a PDF (print), when the 'Export Adobe PDF' prompt comes up, make sure that 'Hyperlinks' (under the 'Include' section) is checked.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]