FORUMS: list search recent posts

Intentisty Pro settings not remaining set

COW Forums : Blackmagic Design

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Rob Grauert
Intentisty Pro settings not remaining set
on Aug 23, 2013 at 10:33:22 pm

I am trying to output video from Premiere Pro CC to my reference monitor via Intensity Pro. This has worked fine in FCP, but I am having issues in PPro.

I'm running Blackmagic Design Desktop Video 9.7.5 on Mountain Lion 10.8.4. In Desktop Video, I change the "Set Output" option to "HDMI & Composite (Y Out) & S-Video." Every time I leave System Preferences and come back, I find that the "Set Output" option has changed back to "HDMI & Component." Anyone know why this would be happening?

Also, "Select Output Processing" is set to "HD to SD Anamorphic," but this isn't changing when I leave System Preferences.

Thanks

Rob Grauert, Jr.
http://www.robgrauert.com
http://www.facebook.com/robgrauertvideo


Return to posts index

Jim Sustacek
Re: Intentisty Pro settings not remaining set
on Aug 27, 2013 at 3:20:25 pm

Same thing happens for me -- must be a Blackmagic bug?

There seems to be a workaround:

1) Open /Library/Preferences/com.blackmagic-design.desktopvideo.prefspanel.plist

(I used the Property List Editor app that comes with or within Xcode, you could also use PlistBuddy in one nice terminal command)

2) Change the value for key "AnalogVideoOutput" from "Component" to "Composite" and save the file. (If you have multiple Blackmagic devices, you will find multiple "AnalogVideoOutput" keys in the plist tree.)

3) Re-open System Preferences and you should see the change. The change seems to hold so well, it seems like the only way to change it back is to edit the plist file again!


Return to posts index

Jim Sustacek
Re: Intentisty Pro settings not remaining set
on Aug 27, 2013 at 4:03:13 pm

Okay, here's a PlistBuddy terminal command that should do the trick (this will affect all Blackmagic devices for a particular system):

for dict in `/usr/libexec/PlistBuddy -c 'Print :' /Library/Preferences/com.blackmagic-design.desktopvideo.prefspanel.plist | awk '{ print $1 }' | grep com.blackmagic-design.desktopvideo.prefspanel`; do sudo /usr/libexec/PlistBuddy -c "Set $dict:AnalogVideoOutput Composite" /Library/Preferences/com.blackmagic-design.desktopvideo.prefspanel.plist; done

It uses sudo so it will probably prompt for a password when you run it.

And to change it back, just switch Composite to Component in the command:

for dict in `/usr/libexec/PlistBuddy -c 'Print :' /Library/Preferences/com.blackmagic-design.desktopvideo.prefspanel.plist | awk '{ print $1 }' | grep com.blackmagic-design.desktopvideo.prefspanel`; do sudo /usr/libexec/PlistBuddy -c "Set $dict:AnalogVideoOutput Component" /Library/Preferences/com.blackmagic-design.desktopvideo.prefspanel.plist; done

Note: I haven't tested this beyond verifying the correct option was selected in the Blackmagic preference pane.


Return to posts index


Rob Grauert
Re: Intentisty Pro settings not remaining set
on Aug 28, 2013 at 1:11:05 pm

Thanks, buddy. I will give it a shot when I get home :)

Rob Grauert, Jr.
http://www.robgrauert.com
http://www.facebook.com/robgrauertvideo


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]