FORUMS: list search recent posts

Decklink SDI card does not work with Windows 7.

COW Forums : Blackmagic Design

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ken Wilson
Decklink SDI card does not work with Windows 7.
on Jan 4, 2012 at 11:46:50 pm

Recently got a second Decklink SDI card for a new capture computer. We've had one card in use for over a year in our studio, capturing pretty much daily, and the issues have been few.
For this new system we were told by Blackmagic that they would only support Windows 7 64-bit. All of our current stuff is XP, but it wasn't a problem as we're going to have to migrate to Win7 eventually.
We build a computer for the card. Nothing fancy, Intel processor on an Intel board, couple of gig of ram, average size hard drive. The only thing that gets installed in Win7, and the Blackmagic card/software.
Problem immediately pops up: Windows does not recognize the driver for the card. Under 'driver properties' I get: "windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source (code 52)"
We try R&R the driver, we R&R the card. We roll back the driver to the 8.5 version. We swap the card with our known good card. None of this works. Note that if we reinstall the drivers without physically removing the card and booting the machine without it in, we get a BSOD with a 'BAD_POOL_HEADER" error. That's usually caused by a driver conflict.
SO, I determine that this problem is beyond my personal capabilities and turn the computer back over to my IT manager. He works on it for the better part of a week, and brings it back to me today. Here's what he did:
1) uninstall and reinstall 9.0 drivers. Still not working
2) reseat card in different PCIe slot. Still not working
3) Test PCIe slots with a different card (A USB port card). PCIe slots work fine.
4) Reformatted hard drive and reinstalled OS and most current versions of all drivers necessary to run. Installed SDI card and 9.0 drivers for it. Still not working. *note that there is NO other software installed beyond Win7 and the BM software*
5) Took a different one of his new system builds that he was already in the process of making, installed windows 7, Decklink card, and 9.0 drivers. Does not work. Note that this was an entirely different build - board, processor, the whole device.
6) Called an outside vendor. They took the card and installed it in one of their win7 machines. Not working.
7) Outside vendor used troubleshooting software to strip all but the very least drivers required for their system to work, reinstalled the Decklink 9.0 drivers manually. Still not working.
8) IT Manager takes original system, formats the HD, and installs WinXP. Decklink software installs correctly on the first try, and works just fine.

I'm not an IT person, but I troubleshoot complicated and cantankerous systems often. I even received a commendation when I was in the Navy for my troubleshooting skills on fighter jets. Therefore I feel fairly confident in saying that the problem is quite likely a compatibility issue between the driver and Windows 7.

The reason why I'm posting this here is for other users' information, as well as to get the attention of Blackmagic. In the past I've had really good tech support on issues, and this time that is not the case. Mostly what I and my IT manager have been getting back from Blackmagic is to do what we just told them didn't work, and that it must be a system compatability issue. Clearly if it doesn't work on 3 different Win7 systems, but does work on one of those systemd when it's rebuilt with XP, it's not a compatibility issue on my end.

That being said, does anyone have any suggestions for fixing the problem with Win7, and has anyone gotten a decklink SDI card to work with Win7?


Return to posts index

Dmitry Kartsev
Re: Decklink SDI card does not work with Windows 7.
on Jan 5, 2012 at 10:35:42 am

hi Ken,
I had same problem. What I did:
1) Format hard drive
2) instal win7

and it started to work. Without formating Hard drive it is not possible to get it work because you probably installed not the latest drivers firstly...you got them from CD. Win 7 is "remember" drivers and new drivers(9.0) works not properly when you are upgrading.
So after formating and install win7 - download latest drivers and install them. Should work.


Return to posts index

Paolo Castellano
Re: Decklink SDI card does not work with Windows 7.
on Jan 5, 2012 at 11:15:01 am

Hello Ken,
we've installed several Decklink SDI in our Win7 64Bit workstations without any problems, with new and old drivers.
What is your system configuration?

Best Regards,

Paolo.Castellano@ivs.it
http://www.ivsEdits.com
-----------------------
"Post Fata Resurgo"


Return to posts index


Ken Wilson
Re: Decklink SDI card does not work with Windows 7.
on Feb 8, 2012 at 9:47:04 pm

Sorry it took me so long to reply - been busy!
The system is as follows:
Intel DH76BL motherboard
Intel I3-2100 quad core processor, clocked at 3.1 ghz.
1.9 Gb ram
Decklink card is installed on one of the PCI Express slots.
I checked all the BIOS, and the drivers are the most current.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]