FORUMS: list search recent posts

Intensity Pro firmware update problem on windows 7 pro 64Bit - UNSOLVED

COW Forums : Blackmagic Design

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
uli kleiner
Intensity Pro firmware update problem on windows 7 pro 64Bit - UNSOLVED
on Dec 30, 2010 at 10:24:59 am

To all experts in this forum!

Is there anyone who has a running system with this:

  • - Windows 7 pro 64Bit
  • - Adobe Premiere CS5 Production Premium
  • - New Intensity Pro with driver 3.9.1


I can install the driver (Control Panel is activ), BUT it requires to update the firmware everytime I boot the system.
When I do this I get an error message and Premiere is kind of blocked (doesn't play clips) (if I cancel the updating, premiere has the same problem).



When I uninstall the driver again, premiere works fine.
I guess it has something to do with the updating process to 64Bit.

Sometime Windows has a shutdown problem (hangs) with this driver too !!

Besides: The complete installation is FRESH!

Is this a known problem?

Blackmagic Support advised to:

- set the User Account Control, UAC to: never notify! - DONE

But the problem remains!

I had an Intensity Card on my older system (Windows XP 32Bit, CS3) and it worked fine!!


Return to posts index

Joshua Helling
Re: Intensity Pro firmware update problem on windows 7 pro 64Bit - UNSOLVED
on Jan 13, 2011 at 7:40:14 pm

Interesting. I am not sure that the UAC would be causing a problem, though it could potentially.

So here's a brief bit on what is happens.

When you install our drivers it installs an application that will check the firmware on the card each time the computer is booted. If during uninstall or install you didn't have admin rights, this program may not have been placed or removed. Obviously it is placed because it tries to run. So my guess is that something may be causing it to run more than once.

When the computer boots it runs this checking utility, until this utility passes the check the Intensity (or deckink for that matter) will run in a sorta, service mode. That is to say it will be detected by the system, but all the options will be greyed out.

So whatever happened is somehow causing the checking tool to believe that the card needs updating every time you boot.

So we need to find out why.

First thing I would do is uninstall the Blackmagic drivers from the control panel. Once that is done go ahead and reboot. When the system comes up, it may prompt you to reinstall drivers, just cancel out.

Now click on start -> run (or newer OS's use the search option) type in MSCONFIG and press enter.

You will see a box come up with a bunch of tabs, click the startup tab.

Scan down that list and if you see any "Blackmagic" related entry, turn it off by unchecking it. Click apply and it will tell you that you need to restart...go ahead. Incidentally when the computer comes back online it will probaly mention that your settings were changed, just tick the box that says don't show this again.

Now navigate to C:\Program Files (x86). You will see a blackmagic folder. If the ONLY Blackmagic product you have is Intensity, then delete the entire Blackmagic folder. If you have other products please go into the Blackmagic folder and remove any Decklink, Multibridge and/or Intensity folders.

Once this is done, please confirm you have the latest version of the Intensity drivers from our website (that's 3.9.4) and run the installer.

Reboot when completed and let's see if that cleared out the problem. If not give us a call and our team can go through more options.

Sincerely,

Joshua
Director of Support
Blackmagic Design Inc.


Return to posts index

Csépe Levente
After installing driver 3.9.4 and Media Express 2.3
on Jan 14, 2011 at 8:46:08 am

Hy Everyone!

I know it's not a clear 'reply' for the main comment of the thread but I found this one the most up-to-date, so if you don't mind I'd ask here. :)

Has anyone noticed difference in displaying from Component source? I currently work with PlayStation 2 video materials and after installing the new combination of driver/software versions, I realized some kind of 'weakness' in colors. I don't feel the intensity in difference among Composite and Component 'anymore'. It's not a huge problem, actually, but before 3.9.4 the display was much better to look, I believe (both with USA or JAP games, changing the IRE settings for NTSC properly as well).

Another thing is about the new features, NTSC/PAL Progressive display formats. I tested it with a 480p capable game but it was unable to display at all. :( The sound was laggy and both in NTSC&PAL progressive forms there was nothing on the screen.

Does anyone else experienced phenomena like these?


Thanks your answers in advance,
Leszko


Return to posts index



uli kleiner
Re: Intensity Pro firmware update problem on windows 7 pro 64Bit - SOLVED
on Jan 18, 2011 at 4:41:42 pm

Thank you a lot Joshua!!

I have solved the problem. I think it was something with my mainboard
- perhaps a kind of incompatibility with the 64Bit system.
Since I have bought a new PC-system (it was already on my to-do-list....)the problem disappeared! So everything runs now ! Thank you for your help again !!

Greetings from Berlin! Uli


Return to posts index

Hidenori Nagao
Re: Intensity Pro firmware update problem on windows 7 pro 64Bit - SOLVED
on Jan 23, 2011 at 5:40:24 pm

Uli

Since you already have solved the problem it may be irrelevant to you anymore, but let me inform you this anyway if this helps.
For Windows Vista or 7, you must disable PCI-Express power saving option to let the installer to upgrade the firmware. This would become an issue if your computer does not have anything other than Intensity (no VGA, sound cards, anything) so that your PCI-Express would remain idle unless you touch this option.

Regards


Return to posts index

Alex Constantinescu
Re: Intensity Pro firmware update problem on windows 7 pro 64Bit - SOLVED
on Feb 13, 2011 at 2:59:04 am

Dear Joshua,

Please try to help me too, because I've just upgraded to an Intel DX58SO2 motherboard with i7 950 processor and after installing the 3.9.4 drivers for Intensity Pro on a fresh Windows 7 64bit, the system started to go slow and eventually froze. I also get random BSODs at boot.

I don't know what to do anymore, I've had it installed on Win7 64bit on the old system (intel board+cpu), and the 3.9.4 drivers worked fine (although I haven't really used the card on Win7, just installed it). After upgrading my system to the new hardware, all hell broke loose.

Please tell me what I can do. Thank you.


Return to posts index


Steve Baxter
Re: Intensity Pro firmware update problem on windows 7 pro 64Bit - SOLVED
on May 21, 2012 at 8:51:01 am

I know this thread is old but the information may still be useful.

I had no end of trouble with the Intensity Pro. On an ASUS M2N68-AM board / Windows 7 64 BIT. The first time I installed the IP in the PCIe X 1 port it worked perfectly for a few weeks. I had an Nvidia NV285 in the PCIe X 16 port to provide dual head graphics. One day in Vegas 11 the Intensity Pro just stopped working altogether. After a reboot the firmware message appeared but the update wouldn't work. After an RMA return BM said the card was working fine so tried removing the NVidia 285 and switching to the motherboard's built in AMD dual head card leaving the IP in the PCIe X 1 port. It still didn't work.

I then moved the IP down to the PCIe X 16 port that the Nvidia used to live in. After booting up the 9.5 driver installed successfully and the Intensity card is now working.

Not an ideal solution but at least it's working :-)


Return to posts index

Bong Sky
Re: Intensity Pro firmware update problem on windows 7 pro 64Bit - UNSOLVED
on Dec 5, 2012 at 4:02:55 am

Dear Sir,

I have the same problem as mention above and I want to download the software but it seem cannot find the software.

Please advise me or give me the direct link.

Thanks,

Kunthy


Return to posts index

Don Harris
Re: Intensity Pro firmware update problem on windows 7 pro 64Bit - UNSOLVED
on Sep 30, 2015 at 2:49:18 am

This problem isn't terribly complex.

The Intensity card is a Windows XP era card and the firmware revisions need to be progressed in steps. If you try to load the latest FW (FW=FirmWare) without loading the prior FW first, the latest one won't load.

So the simple solution is to load the older FW 1st, then upgrade to the latest. The break point for the Intensity seem to be version 9 FW. You can still download the version 9.8 software from the BMD support page (it is called: Desktop Video 9.8 dated 06/10/2013).

Now you may ask "well can't I see what version of FW is already on the card ?" - the short answer is no. BMD chooses not to share that with us. You can use the SDK to see that information, but frankly it doesn't matter much.

So the steps are:

Un-install whatever desktop video version you have installed (skip this if you haven't installed any of the BMD software yet on your Win764 machine).

Download Desktop Video 9.8, install it. During the installation, you may be asked to reboot a couple of times, this is normal.

You can now either jump straight in and download 10.5 (latest as of this post) or whatever the latest is and install it. It too will need you to reboot once or twice and you should be good to go.

If you want to be more cautious, I stopped after installing version 9.8 and tested the card inputs and changed and saved different settings. A word of caution, if the card won't let you select anything but the HDMI input, this means that the BMD software hasn't gotten "active control" of the card, but instead is using the default preferences (this is kind of a half way there situation). In other words, changing inputs and saving these (using the "Blackmagic Desktop Video Utility" - which you launch from within the Control Panel) is the way you test the card talking properly to the utility (and eventually the application you want to use).

Also, I don't know how far back these FWs for intensity go, but some of my cards are dated 2010 - and the original install SW says "Intensity 3.9.1", so this could mean FW version 3.9. But since I don't really know what firmware I am starting from, I am not sure knowing really matters much. I have successfully upgraded 14 cards so far, all with various manufacturing dates, so I think you don't need to go back any farther than FW version 9.8 (at least I haven't yet).

A couple of other issues to look at:

Win7 Power management is a bit aggressive and shuts off cards when not in use, so set to "high performance mode", which leaves the cards running all the time (one of the potential problems here is the card won't be visible to Win7 when it tries to write the FW onto the card, so it throws up the "firmware failed" error". I haven't always made this change after I started using the "burn FW V9.8 first" approach, so I can't say this is critical to success.

Your PCIe slots in the BIOS (yeah I said that) need to be set to Generation 2 versus 3. This is a comment made by a BMD guy and I doubt most users will have this option in their BIOS, I haven't tested it one way or the other.

Life is goo


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]