FORUMS: list search recent posts

Solved RS-422 problem with decklink studio card

COW Forums : Blackmagic Design

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Remco Wiekard
Solved RS-422 problem with decklink studio card
on Mar 15, 2009 at 8:53:05 am

A few weeks ago my company bought me a new Macpro with a decklink studio card. After installing Final Cut Studio I tried to connect to a Digibeta DVW A-500P. The decklink card said No Comm. After trying to connect via a standard Sony RS-422 cable still no Comm. I could connect to any other device (DV, XDCam, J3) so it had to be something with the protocol in the driver. After contacting BM support, they told me to connenct pin 2 to pin 8 and the other way around in the RS-422 cable. That indeed solved the problem. Ik hope sharing this info with new studio card users will help you.

MacPro dual Quad 2,8 GHz - 16 GB RAM - Blackmagic Studio - FCP 6.05 - OSX 10.5.5 - G5 2,0 GHz - 4 GB RAM - Decklink Extreme - FCP 6.05 - OSX 10.5.5


Return to posts index

Bob Zelin
Re: Solved RS-422 problem with decklink studio card
on Mar 17, 2009 at 2:05:14 am

I cannot believe that this worked. Every Sony VTR uses a "straight through" cable - pin 1 to pin 1, pin 2 to pin 2, etc, etc. This is every RS422 cable for every professional VTR since the linear video days.

the DVW-A500 Remote 1 IN port is a standard RS422 port. Cross wiring the pins does not make it work. I don't know exactly what is going on at your place, but I cannot believe that you are going into the RS422 Remote 1 IN port on your VTR. A straight thru cable should absolutely work.

bob Zelin




Return to posts index

Remco Wiekard
Re: Solved RS-422 problem with decklink studio card
on Mar 17, 2009 at 6:56:08 am

I don't understand why it works, but it does. The only thing I do know is that when I used a straight sony rs-422 cable, the studio card did not see a machine. Crosswiring solved that problem. Blackmagic gave me that solution and it solved the problem

MacPro dual Quad 2,8 GHz - 16 GB RAM - Decklink Studio - FCP 6.05 - OSX 10.5.6 - G5 dual 2,0 GHz - 4 GB RAM - Decklink Extreme - FCP 6.05 - OSX 10.5.6


Return to posts index


Jay Cordova
Re: Solved RS-422 problem with decklink studio card
on Apr 2, 2009 at 6:19:14 pm

Well, go figure. Switching pins 2 and 8 does indeed work. Thanks a ton.

I didn't mention that not only could I not control the digibeta A500, but I had no machine control with the Panasonic HD-1200A either.

With the pinouts switched, I have control over all of the machines now (BetaSP 1800, Digi M2000, Digi A500 & Panasonic HD-1200).

I do not understand, and I'm an engineer type. At this point, though, I don't need to. It works.

Thanks again.

So those of you with the same problem (or similar with other decks not mentioned here) might consider this "solution", even though your engineering brain says "no".


J. Cordova
Springboard Creative/Atlanta


Return to posts index

Robert Nicol
Re: Solved RS-422 problem with decklink studio card
on May 11, 2012 at 3:01:06 am

This is actually a well-known issue from way back when D1 machines were having problems connecting to a Quantel box after Sony introduced the personality concept. Swap the pins in one end of the cable.


Return to posts index

Jay Cordova
Re: Solved RS-422 problem with decklink studio card
on Mar 24, 2009 at 10:36:50 pm

Well, darned if I don't have exactly the same problem. Just got a Decklink Studio, can connect to everything else EXCEPT the DVW-A500.

I hesitate to cross over the wiring for sure but am at my wits end. Gotta be something with the protocol in the Studio card, because the former Decklink card that just came out worked fine controlling all machines.

I haven't contacted Decklink support. I can't believe this crossover worked either, and the Blackmagic folks suggested this solution to deal with the A500? Hmmmmm.

Anyone else with the same problem - Decklink Studio won't work with DVW-A500?

J. Cordova
Springboard Creative/Atlanta


Return to posts index


Remco Wiekard
Re: Solved RS-422 problem with decklink studio card
on Mar 25, 2009 at 12:14:06 pm

here is the original mail i got from B;ackmagic design.

"We believe that this may be a grounding issue, similar to your
customer who tried to ground pins together. The current solution is
we have a small RS422 pin map cable, which so far has shown to solve
the problem in our testing. This will need to be attached to the back
of the Decklink card, and then the RS422 cable run as normal.
This problem will now be examined further in hardware/firmware and an
appropriate solution found."

Pin out of the pin map cable is:

Cross pin 8 (Receive A) and pin 2 (Transmit A).

8 > 2
2 > 8


MacPro dual Quad 2,8 GHz - 16 GB RAM - Decklink Studio - FCP 6.05 - OSX 10.5.6 - G5 dual 2,0 GHz - 4 GB RAM - Decklink Extreme - FCP 6.05 - OSX 10.5.6


Return to posts index

Jay Cordova
Re: Solved RS-422 problem with decklink studio card
on Mar 25, 2009 at 4:22:53 pm

Thanks. So you have this crossover engaged, and are you still able to control other machines, or are you strictly hooked up RS-422 to the A-500?



J. Cordova
Springboard Creative/Atlanta


Return to posts index

Remco Wiekard
Re: Solved RS-422 problem with decklink studio card
on Mar 26, 2009 at 6:20:23 am

I'm still able to control any other machine (suchs as xd cam 1500, betacam J3, several DV decks). I am connected to a rs-422 switch in the machine-room.
This is just a temporary solution. I think that Blackmagic will speed up the proces of making a new driver to solve this problem. But in the mean time, I can connect to a DVW-A500

MacPro dual Quad 2,8 GHz - 16 GB RAM - Decklink Studio - FCP 6.05 - OSX 10.5.6 - G5 dual 2,0 GHz - 4 GB RAM - Decklink Extreme - FCP 6.05 - OSX 10.5.6


Return to posts index


Michiel van Haren
Re: Solved RS-422 problem with decklink studio card
on Apr 7, 2009 at 10:30:18 am

I've got exactly the same problem here. No RS422 control with our DVW 500P digibeta deck.
Hopefully BM will fix this in an update soon!


Return to posts index

Martin Eberle
Re: Solved RS-422 problem with decklink studio card
on Apr 24, 2009 at 1:30:45 pm

Well, the 7.1 upgrade didn't solve the problem. That is really annoying, I am not really experienced with the cutting of cables. Shouldn´t Blackmagic supply it´s customers with a free cable to get everything working?


Return to posts index

Martin Eberle
Re: Solved RS-422 problem with decklink studio card
on Apr 24, 2009 at 2:48:32 pm

Just got a call from Die Agenten from Munich: Blackmagic will provide a cable but a software upgrade is ahead to fix the problem. Strange, didn´t Balckmagic test the remote or was it that they just didn´t care?


Return to posts index


Osama Mneina
Re: Solved RS-422 problem with decklink studio card
on May 19, 2009 at 8:41:36 pm

I had the same prob. I bought a straight pin to pin RS-422 but did not work. Deklink SDI says no comm. I then rewired the cable with cross wires (2>8 and vise versa) and it worked. Thanks to this thread.


My equipment are:
DVW-M200P DigiBeta
Deklink SDI
Windows Core2duo Quad 2.4Ghz with 4GB Ram and 2T RAID0 Samsung HDD


Return to posts index

Andre Welkin
Re: Solved RS-422 problem with decklink studio card
on May 12, 2011 at 10:34:14 am

Hi there i have the same problem, i have a Decklink Extreme 3d and my RS422 also does not want to work. Please can i ask if you can mail me a diagram as to what you mean cross wire and change Pin 2 and 8 around. here is my mail address andrecwelkin@yahoo.com.


Many Thanx Andre


Return to posts index

alejandro gonzalez
Re: Solved RS-422 problem with decklink studio card
on Sep 1, 2011 at 10:09:11 am

Hi, I don't know how it has to be made. I have a DVW-2000P and the remote doesn't work. Please, send me a mail to alejandro.gonzalez@hotmail.es or upload an image... THANKS!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]