Creative COW SIGN IN :: SPONSORS :: ADVERTISING :: ABOUT US :: CONTACT US :: FAQ
Creative COW's LinkedIn GroupCreative COW's Facebook PageCreative COW on TwitterCreative COW's Google+ PageCreative COW on YouTube
ADOBE PREMIERE PRO:HomeTutorialsForumArticlesPodcastsBasics ForumCreative Cloud Debate

Losing Superwhites

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook
Mike JacksonLosing Superwhites
by on Sep 5, 2012 at 6:22:03 pm

I originally posted about this in the After Effects forum, with no solutions, and now I've discovered it's happening in Premiere as well. Both programs are clipping the superwhites from the XD-Cam footage I'm cutting.

In AE, no combination of color depth, color management and profile settings seems to restore the lost hilight data. Premiere doesn't seem to have a lot of options in that regard, but the result is the same.

I'm on a MacPro running Snow Leopard, Adobe CS6, with a Blackmagic decklink going out to a Flanders Scientific monitor. In Final Cut Classic, the waveform clearly shows data above 100 IRE. In both Premiere and AE, waveforms show it gone, both on my FSI monitor and the software scopes. No amount of fiddling with color correction brings it back either.

The AE issue seems to come up frequently on the web, but is never really solved. Now I'm wondering if it's a bigger issue - Is it the Mercury Playback Engine? Is it (gulp) my graphics card? If anyone has any insights, that would be fantastic. I'd really like to get off of FCP and onto Premiere for all my projects, but not if it damages all the doc footage I'm cutting.


Return to posts index
Reply   Like  

Donald NelsonRe: Losing Superwhites
by on Sep 6, 2012 at 3:35:56 pm

In CS3, I can most of the time recover detail lost in superwhite by using the Shadow/Highlight effect and deselecting "Auto Amounts" and adjust the "Highlight Amount" to regain some of the lost detail.

Don Nelson
Sainte Television Group


Return to posts index
Reply   Like  

Mike JacksonRe: Losing Superwhites
by on Sep 16, 2012 at 12:03:44 am

Been working on other things for the last few days, finally had a chance to try your suggestion... but no, all it's doing is adjusting the data remaining below 100 IRE. The clipped data is still gone.

So, surely I'm not the only person to have looked at the waveforms for XDCam and HDV footage in Premiere, and seen this problem. Is this issue new to CS6?

Is there anyone from Adobe reading these forums who can point me to a way to keep Premiere and AE from clipping my superwhites?



Return to posts index
Reply   Like  


Jarle LeirpollRe: Losing Superwhites
by on Sep 16, 2012 at 6:41:13 pm

Mike, if you're losing super-whites, you're working in 8-bit mode instead of 32-bit mode. If you have an approved graphics card, all of the calculations will happen in 32-bit float. If you don't, the software mode defaults to 8-bit. You can change that to "Max Bit Depth" in Sequence settings. Go here for a list of compatible cards:
http://www.adobe.com/products/premiere/tech-specs.html

If you're actually working in 32-bit, and still losing overbrights, you're blocking the 32-bit-ness with an 8-bit effect.

Also make sure you're actually losing overbrights, not just missing them on the scopes. The scopes are always rendered in software (and therefore 8-bit), and will show clipping even though no clipping is happening in 32-bit.

Read all about color correction and grading in Premiere Pro here: http://premierepro.net/editing/chapter-on-color-grading-in-premiere/


Return to posts index
Reply   Like  

Mike JacksonRe: Losing Superwhites
by on Sep 16, 2012 at 8:12:16 pm

Thanks for the response.

Sequence settings *are* set to Max Bit Depth (and 32-bit in AE). I've heard this mentioned before, yet have seen no change in my results.

I'm not using ANY effects, 8-bit or otherwise. Just viewing the clean footage itself. In both programs, all super-whites are clipped, and the fact that I can't retrieve the data using ANY filters or settings seems to indicate the data is being thrown out at the earliest stage of processing.

The scopes I'm referring to that I'm using are the ones built into my Flanders Scientific monitor, which shows superwhites quite effectively. Signal is going out through a Blackmagic Decklink. When I look at this footage in Final Cut classic, supewhites are present. In Premiere and AE, they're gone. On the off chance I was being lied to somehow, I tried various methods of exporting back out of Premiere and AE, at various gamma levels, using Proc. Amp, etc, and brought back into FCP - But the data was still gone... so I don't think the scopes are lying to me.

So the only thing left on your list is my graphics card. I'm using a GTX480 with CUDA acceleration and Mercury Playback enabled. It's not on your list, but it's been enabled by editing the Cuda Supported Cards text file, and is working like a DREAM for all playback, and for ray-trace rendering in After Effects. But could that be the cause, and it's defaulting to 8-bit? If so, that would seriously suck, as there's painfully few reasonable card options for MacPros at present.

Is there ANY way to get around this, other than dropping 2k on a Quadro card that will (according to benchmarks I've seen on the Cow) actually render Ray-Traced 3D in AE *slower* than my GTX 480?



Return to posts index
Reply   Like  

Jarle LeirpollRe: Losing Superwhites
by on Sep 16, 2012 at 9:17:16 pm

If you've "hacked" the card, that is not the cause of the problem. CUDA is either on or off. Nothing in between. I use a lot of XDCAM-EX material, and my superwhites are retained all through the chain. But I don't have a third-party card attached - I'm using a DreamColor monitor via 10-bit DisplayPort connection.

So the problem doesn't seem to lie in the software or the output from the software. I would guess it's the Matrox card that's doing the clipping. Hope you find out what's wrong. Good luck!


Return to posts index
Reply   Like  


Jarle LeirpollRe: Losing Superwhites
by on Sep 16, 2012 at 9:20:03 pm

Sorry, I meant the BlackMagic card - not Matrox.


Return to posts index
Reply   Like  

Mike JacksonRe: Losing Superwhites
by on Sep 17, 2012 at 12:45:18 am

Hmmm. Well, since the Blackmagic card works fine with Final Cut classic, I know it can't be an intrinsic problem with the card itself. (And as an aside, I'm outputing through SDI.)

That would lead me to Adobe's video output code or Blackmagic's drivers, and how they interact... But if that was the case, then logically the superwhites should still BE in the shots, even if they weren't displaying out to my monitor, and lowering the whitepoint (and a zillion other filters or functions) should 'reveal' the lost info.

And yet, that's not the case. And of course the waveform on my monitor and in Premiere both look pretty much identical, and again, if the problem was my I/O board, those waveforms should differ.

This is quite the head-scratcher, to put it lightly. And yes, my card is hacked, and seems to function perfectly... but your original suggestion that somehow everything is locking into 8-bit seems to be the only thing that might explain it all...?

WOW would I love to pick the brain of an Adobe engineer...



Return to posts index
Reply   Like  

Mike JacksonRe: Losing Superwhites
by on Sep 22, 2012 at 7:42:17 pm

Well, further bashing at the problem led to some further discoveries... which I'm only posting on the off-chance someone searches for answers to the same problem, and comes upon this thread.

Both Premiere and After Effects DID preserve my super-whites on NTSC footage... which led me to re-test everything. Looks like someone 'helped me out' by re-transcoding the show's XD-Cam footage, and clipped off the super-whites then. Nice.

HOWEVER - What I CAN confirm is that *HDV* is hooped. Nothing I can do in either program will preserve values above 100IRE. Looks to me like a very codec-specific color interpretation problem. Only work-around I've found is re-transcoding before bringing it in, but it's a pain and has inherent quality loss. Would be great to get that fixed...



Return to posts index
Reply   Like  


Jarle LeirpollRe: Losing Superwhites
by on Sep 22, 2012 at 9:09:55 pm

That explains a lot. :-)

When someone's already clipped the superwhites, Premiere will not magically bring them back. :-) But the HDV issue is not caused by the same thing, right? You are capturing the clips in Premiere and getting MPG-files? Or are they wrapped in a MOV because they were captured in another piece of software?

Just had to ask. :-)


Return to posts index
Reply   Like  

Mike JacksonRe: Losing Superwhites
by on Sep 29, 2012 at 7:30:21 pm

Sorry for the delayed response. Busy week.

I was handed the project with all footage already digitized, most likely in Final Cut. HDV was in a Quicktime wrapper... and all supewhites were still showing in Final Cut.

In the end, I used Compressor to transcode everything to ProRes, and all my superwhites came back in Premiere and After Effects. So as I say, looks like an interpretation issue with HDV in the Adobe suite. Maybe HDV works better in non-Quicktime wrappers, or if captured directly in Premiere, but at this point I just don't have the time (or source tapes) to do tests...



Return to posts index
Reply   Like  

Jarle LeirpollRe: Losing Superwhites
by on Sep 29, 2012 at 11:15:48 pm

Aha! MOV wrapper is a bad thing.

HDV is MPEG, and should be stored as MPEG files. FCP does wrap it in MOV just because, well - it has to. When Premiere imports a .MOV file with MPEG, it uses the 32-bit QuickTime importer (from Apple). Bad things can happen because Apple doesn't want PC users to have much fun. If Premiere imports an .MPEG file on the other hand, it will use its own built-in 64-bit MPEG-importer. Good things will happen.

Just so others can learn from your experience; Could you try renaming a few of the files from .MOV to .MPG and re-import and see if that magically restores the super-whites?


Return to posts index
Reply   Like  


Mike JacksonRe: Losing Superwhites
by on Oct 2, 2012 at 8:12:19 pm

YOU NAILED IT. Renaming the HDV as .mpg instead of .mov brought back my superwhites!

That's kind of hilarious... and a shame it took so long to sort out, as I burned a lot of time transcoding the footage to ProRes, and the show is already delivered.

Still, great to know what the issue is, and how to resolve it!



Return to posts index
Reply   Like  

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook


FORUMSTUTORIALSFEATURESVIDEOSPODCASTSEVENTSSERVICESNEWSLETTERNEWSBLOGS

Creative COW LinkedIn Group Creative COW Facebook Page Creative COW on Twitter
© 2014 CreativeCOW.net All rights are reserved. - Privacy Policy

[Top]