Creative COW SIGN IN :: SPONSORS :: ADVERTISING :: ABOUT US :: CONTACT US :: FAQ
Creative COW's LinkedIn GroupCreative COW's Facebook PageCreative COW on TwitterCreative COW's Google+ PageCreative COW on YouTube
ADOBE PREMIERE PRO:HomeTutorialsForumArticlesPodcastsBasics ForumCreative Cloud Debate

Video playback problem - Nvidia 650M graphics card with CUDA 'hack' on new Macbook Pro

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook
Sarah CrozierVideo playback problem - Nvidia 650M graphics card with CUDA 'hack' on new Macbook Pro
by on Jul 2, 2012 at 9:38:13 am

Hi, Hoping someone may have some suggestions.

I have a new (mid 2012) Macbook Pro with Nvidia 650M graphics card - I've used the 'hack' to enable the Mercury Playback Engine CUDA acceleration in Premiere Pro CS5.

The issue is that although Mercury Playback Engine GPU acceleration is enabled in the Premiere Pro projects, the video footage (AVCHD Canon .mov, FS100 AVCHD and Sony F3 Mpeg2) does not playback in the video monitor - it just shows a black screen or a still of the first frame (although the audio plays back ok).

When I switch to Mercury Playback Engine Software Only in the project, the video files do play back (although the render bar above them on the timeline has switched from yellow to red). There is no downloadable driver for the 650M card on the NVIDIA site. I tried installing an earlier version of CUDA driver (4.0.19), but that only disabled the GPU accelerator option in the Premiere project.

Thanks for your help,
Sarah

Specs for my system:

Macbook Pro Mid 2012
Mac OSX Lion 10.7.4 (latest updates)
2.7 GHz Intel Core i7
8GB DDR3 RAM
NVIDIA GeForce GT 650M with 1GB memory

Premier Pro CS5
CUDA driver 4.2.10 (latest version)


Return to posts index
Reply   Like  

Juan SalvoRe: Video playback problem - Nvidia 650M graphics card with CUDA 'hack' on new Macbook Pro
by on Jul 2, 2012 at 11:54:29 am

I've found performance is actually far better using the OpenCL mercury engine on the 650M. Additionally I assume you've restarted the system since having this black iimage display issue?

Colorist | Online Editor | Post Super | VFX Artist | BD Author

http://JuanSalvo.com


Return to posts index
Reply   Like  

Sarah CrozierRe: Video playback problem - Nvidia 650M graphics card with CUDA 'hack' on new Macbook Pro
by on Jul 2, 2012 at 1:09:12 pm

Thanks Juan, yes, I restarted - but I'm using CS5, which I don't believe supports OpenCL - I can't afford CS6 at the moment. I've been searching and haven't found anyone else with a similar problem - but I guess a lot of people will be moving to CS6.

Sarah.


Return to posts index
Reply   Like  


George MonteiroRe: Video playback problem - Nvidia 650M graphics card with CUDA 'hack' on new Macbook Pro
by on Jul 6, 2012 at 5:43:53 pm

You can't afford $24.99 per month for the entire suite of Adobe products? You will never see a price like that again after August.

I unfortunately just bought a new Macbook to take advantage of that deal and bought the latest model (non retina) with the Nvidia 650M with 512 Vram and installed all my software only to find the Mercury playback engine only works in software mode. I hope I can return it for an older model that works. Does anyone know how much power for other apps I will be sacrificing if I go with the And 6750 or 6770?


Return to posts index
Reply   Like  

Teofisto MagalpokRe: Video playback problem - Nvidia 650M graphics card with CUDA 'hack' on new Macbook Pro
by on Aug 1, 2012 at 12:30:11 pm

@ Sarah & George:

MBP's with the GT650M, come in two variants:

1.) 15-inch 2.3GHz NVIDIA GeForce GT 650M with 512MB of GDDR5 memory

2.) 15-inch 2.6GHz NVIDIA GeForce GT 650M with 1GB of GDDR5 memory and automatic graphics switching

Though the number of CUDA cores in the GT650M is way above the minimum of 96-cores, Mercury Playback Engine will only work properly if your VRAM is at least 896MB. Having the MacBook Pro as configured in #2, I'm sure you wouldn't have a problem running MPE!

Hope this helps...


Return to posts index
Reply   Like  

vu thaiRe: Video playback problem - Nvidia 650M graphics card with CUDA 'hack' on new Macbook Pro
by on Sep 2, 2012 at 10:38:43 pm

I have the exact problem, but I have a geforce 680 w/ 2 gigs of vram. Have no idea why I can't see the video.


Return to posts index
Reply   Like  


Adam GuzewiczRe: Video playback problem - Nvidia 650M graphics card with CUDA 'hack' on new Macbook Pro
by on Sep 7, 2012 at 9:24:15 pm

Same here on a gtx 570 on a mac


Return to posts index
Reply   Like  

Matiatus VoidRe: Video playback problem - Nvidia 650M graphics card with CUDA 'hack' on new Macbook Pro
by on Mar 3, 2014 at 1:17:08 pm

I have the exact same problem with exact same hardware. I've found the same issue mentioned elsewhere in the Adobe forum but the thread just tailed off with no conclusion. Will an upgrade to CC fix this? My mac can't cope with the projects I'm throwing at it!


Return to posts index
Reply   Like  

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook


FORUMSTUTORIALSFEATURESVIDEOSPODCASTSEVENTSSERVICESNEWSLETTERNEWSBLOGS

Creative COW LinkedIn Group Creative COW Facebook Page Creative COW on Twitter
© 2014 CreativeCOW.net All rights are reserved. - Privacy Policy

[Top]