Creative COW SIGN IN :: SPONSORS :: ADVERTISING :: ABOUT US :: CONTACT US :: FAQ
Creative COW's LinkedIn GroupCreative COW's Facebook PageCreative COW on TwitterCreative COW's Google+ PageCreative COW on YouTube
SONY VEGAS:Sony Vegas TutorialsSony Vegas ForumArticlesBasics ForumBlack Magic Design ForumAJA Xena Forum

Rendering with 5.1 audio "an error occurred while opening a codec"

COW Forums : Sony Vegas

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook
Jason GarrisonRendering with 5.1 audio "an error occurred while opening a codec"
by on Sep 26, 2011 at 10:43:37 pm

Hello

I have just recorded my first footage in 5.1 surround with my new Canon mic and Canon Vixia HF G10 camcorder. I imported a clip into Sony Vegas Studio HD Platinum 11 in order to quickly render it and test it out on my surround system. I have hit a snag. Everytime I try to render the clip I get the message "an error occurred while opening a codec."

I have set my progect audio settings to 5.1 surround. Vegas recognizes the file as 5.1 surround as front, center, LFE and rear audio track lines are visible in the editor. The video is mt2s (AVCHD). I am using a customized "internet" template under the Sony AVC heading on the render menu.

Can anyone tell me where I have gone wrong?

Any help would be greatly appreciated. I am still a newbie, trying to learn all this stuff.


Jason


Return to posts index
Reply   Like  

Mike KujbidaRe: Rendering with 5.1 audio "an error occurred while opening a codec"
by on Sep 27, 2011 at 1:33:38 am

I played around with some 5.1 AVCHD footage I grabbed from the net and found that I had to set the audio bitrate to 256,000 before I stopped getting the error message.
Even then, the mp4 render only seemed to be in stereo (at least when I imported it back into Vegas.
Hopefully someone who does this more than I do can answer why that happens.


Return to posts index
Reply   Like  

Jason GarrisonRe: Rendering with 5.1 audio "an error occurred while opening a codec"
by on Sep 27, 2011 at 2:05:14 am

Thanks for the response.

I set the bitrate to 256 as you suggested and the file did render. Also as you said the rendered file appears only to be in stereo (at least that's the way windows reads it). It may be it just needs decoding(?). I've heard that dd 5.1 isn't truly 6 separate channels, but a stereo track coded to send certain signals to different channels when decoded. Don't quote me on that, I'm not positive that is the case. I'm going to go try and play it on my surround system and see what happens.

Thank you again.

Jason


Return to posts index
Reply   Like  


Mike KujbidaRe: Rendering with 5.1 audio "an error occurred while opening a codec"
by on Sep 27, 2011 at 2:55:30 am

I'll be very curious to see what you find out.


Return to posts index
Reply   Like  

Jason GarrisonRe: Rendering with 5.1 audio "an error occurred while opening a codec"
by on Sep 27, 2011 at 3:19:50 am

Hi again

So the supposedly 5.1 surround rendered file reads only as stereo on my surround reciever. Bummer. I can have "fake" surround sound by having the reciever manipulate it into DTS Neo 6 or DDPLII but that can be done with any stereo track.

I experimented a bit, importing the same file into Vegas with the 5.1 soundtrack and then with only a stereo track. I rendered both files and the one that imported with only two channels sounds better than the one imported with 6 channels which were down-mixed in the rendering (Down-mixing apparently loses significant information).

The video was shot in native 24p, but I also test rendered the sucker in an AVCHD 1080 60i 5.1 surround preset template but Vegas output it with only a stereo track as well (and the loss of video quality was quite noticeable)

I paid an extra $40 to get the Canon surround mic vs. the regular stereo version. That may have been a mistake. It appears to me that if I want full HD at 24p with a surround soundtrack I am going to have to invest in a bluray burner. I hope this is not the case. I hope somebody out there has a solution.

Thanks again.

Jason


Return to posts index
Reply   Like  

Mike KujbidaRe: Rendering with 5.1 audio "an error occurred while opening a codec"
by on Sep 27, 2011 at 12:53:16 pm

"I paid an extra $40 to get the Canon surround mic vs. the regular stereo version. That may have been a mistake. It appears to me that if I want full HD at 24p with a surround soundtrack I am going to have to invest in a bluray burner. I hope this is not the case"

You have a camcorder that shoots in full 1929 x 1080 24p HD so a Blu-ray burner is the only way to get what you want.
A regular DVD limits you to 720 x 480.
A decent burner is under $200 these days.


Return to posts index
Reply   Like  


Christoph KurpinskiRe: Rendering with 5.1 audio "an error occurred while opening a codec"
by on Dec 3, 2011 at 11:08:02 am

Gent's, this behaviour is similar to Vegas Studio 10. Import of 5.1 audio is still NOT SUPPORTED. I have Panasonic AVCHD with 5.1 audio and I'm looking since years for payable solution below Vegas Pro. Vegas Studio 11 "mix-down" 5.1 audio to stereo. You can of course create 5.1 Surround projects and create 5.1 effects but not from your original audio file. Big marketing promises without real value.

Chris


Return to posts index
Reply   Like  

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook


FORUMSTUTORIALSFEATURESVIDEOSPODCASTSEVENTSSERVICESNEWSLETTERNEWSBLOGS

Creative COW LinkedIn Group Creative COW Facebook Page Creative COW on Twitter
© 2014 CreativeCOW.net All rights are reserved. - Privacy Policy

[Top]