Creative COW SIGN IN :: SPONSORS :: ADVERTISING :: ABOUT US :: CONTACT US :: FAQ
Creative COW's LinkedIn GroupCreative COW's Facebook PageCreative COW on TwitterCreative COW's Google+ PageCreative COW on YouTube
SONY VEGAS:Sony Vegas TutorialsSony Vegas ForumArticlesBasics ForumBlack Magic Design ForumAJA Xena Forum

Sony Vegas Pro 9 - Rendering in HD-System Memory Low

COW Forums : Sony Vegas

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook
James LamprechtSony Vegas Pro 9 - Rendering in HD-System Memory Low
by on Jun 5, 2010 at 5:51:12 pm

Hi Folks,

I have tried several suggestion from Creative Cow, awesome resource by the way THANKS!

I am in a jam with some HD Rending however in Sony Vegas Pro 9:

I can't seem to get a successful render in HD with Sony Vegas Pro 9. I either get system memory too low with AVI format or Unmanaged Exception (0xc0000005) trying other formats. I am able to render projects for NTSC with AVI but not HD.

I have a Pentium 3.2GHz processor, 3.5 GB of RAM and two hard drives on the computer, Drive C 298 GB with 92 GB free and Drive D 932 GB with 298 GB free. I also have a portion of each hard drive set up for virtual memory: C with 150 GB paging file and D with 500 GB paging file. My high definition video is on an external harddrive with 2 TB of which 1302 GB is free. I have tried to render to both drive D and to the external hard drive, there should be plenty of room.

I am at my wits end. Please help. I have several projects to finish and they need to be in HD.


James L.


Return to posts index
Reply   Like  

John RofranoRe: Sony Vegas Pro 9 - Rendering in HD-System Memory Low
by on Jun 5, 2010 at 7:35:58 pm

How will you deliver your HD video? Why are you trying to render HD to AVI? Have you tried MPEG2 with the Blu-ray templates?

BTW, your PC is not up to spec for HD. Vegas requires a dual core at a minimum for HD.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index
Reply   Like  

James LamprechtRe: Sony Vegas Pro 9 - Rendering in HD-System Memory Low
by on Jun 7, 2010 at 2:40:32 am

John,

I kept searching the archives and have found another comment you made regarding HD not being compatable with pictures over 2mg and was able to successfully render to .wmv in HD. I am rendering now per your suggestion to MPEG2.

I thought since I could render in HDV (with wmv) I could burn an HD disc in DVD Architect Pro 5 but now I see it will be NTSC unless I burn to Blu Ray, correct?

As far as AVI format I heard that is best but it was on a youtube tutorial not on creative cow. It ended up splitting up into several avi files which I am not pleased about. Do you suggest I stick with MPEG2?

I used to have a different raid set up on my pc which I beleive was dual core but switched it over to enable me to install a bigger hard drive. I may need to switch it back.

Thanks for your expertise!

James L.


Return to posts index
Reply   Like  


James LamprechtRe: Sony Vegas Pro 9 - Rendering in HD-System Memory Low
by on Jun 7, 2010 at 3:00:36 am

John,

Regarding your questions:

"How will you deliver your HD video?" - I see now that DVD architect 5 only burns HD in Blu Ray. Without Blu Ray I gather the DVD will be in NTSC and not in HD, correct?

"Why are you trying to render HD to AVI?" - I had heard that avi was the best format in a tutorial on youtube, should have stuck with creative cow! The avi files ended up as several split files in my computer.

"Have you tried MPEG2 with the Blu-ray templates?" - No as I do not own a Blu Ray Player.

"BTW, your PC is not up to spec for HD. Vegas requires a dual core at a minimum for HD." - Sorry I was confused, I checked on the processor which is dual core running on 3.2 ghz, sorry for the reference on the raid set up as I gather that is not what you were referring to.

Not sure if you got the last post but after removing the large photos from the project and increasing the virtual memory on the computer I was able to burn in HD format using wmv. I am trying the MPEG2 now.

Very appreciative of your help John!


Thanks,



James L.


Return to posts index
Reply   Like  

John RofranoRe: Sony Vegas Pro 9 - Rendering in HD-System Memory Low
by on Jun 8, 2010 at 3:17:07 am

"How will you deliver your HD video?" - I see now that DVD architect 5 only burns HD in Blu Ray. Without Blu Ray I gather the DVD will be in NTSC and not in HD, correct?
Correct.
"Why are you trying to render HD to AVI?" - I had heard that avi was the best format in a tutorial on youtube, should have stuck with creative cow! The avi files ended up as several split files in my computer.
While AVI can use codecs that are higher quality than MPEG2, if you are making a DVD it must be in MPEG2 format so there is no advantage in making an AVI file.
"Have you tried MPEG2 with the Blu-ray templates?" - No as I do not own a Blu Ray Player.
So... how do you play to watch HD without a Blu-ray player? You could use an HD media server but you need something other than a DVD player to watch HD.
Not sure if you got the last post but after removing the large photos from the project and increasing the virtual memory on the computer I was able to burn in HD format using wmv. I am trying the MPEG2 now.
Glad to hear you are making progress.
Very appreciative of your help John!
You're very welcome.

~jr

http://www.johnrofrano.com
http://www.vasst.com



Return to posts index
Reply   Like  

Shaun YeeRe: Sony Vegas Pro 9 - Rendering in HD-System Memory Low
by on Jul 10, 2010 at 7:12:31 am

I've been rendering fine in 32 bit Vegas Pro 9.0 for a very, very long time (like a year or two)while updating all the time. However, just a week ago, the same exact problem happened to me, for HD or SD, depending on how large of a file it was rendering.

Sometimes it says "system memory low", and other times, it says "Sony Vegas has stopped working" and the program closes. I've heard that customer service isn't much help either...

By the way, I recently upgraded to a 64 bit OS, so I installed the 64bit version of Vegas Pro 9.0. It's been going fine for 64-Bit Vegas...

And, apparently there's another trick you can do with the 32 bit version of Sony Vegas (which most people have).



Here's the Trick:

Download "CFF Explorer" (just google it, it's free and safe) and install it. What CFF Explorer does is it can tweak ".exe" files and make them handle more than the standard 2 Gigabytes that all 32 bit applications usually handle on your PC.

FOR 64-BIT OS USERS:

These instructions are from a Sims 3 Forum where the 32 bit application for the game was also tweaked.
There are multiple ".exe" ending files in Vegas Pro, but tweaking just one of them apparently helps:

1) Download and install CFF Explorer(http://www.ntcore.com/exsuite.php)

2) Run the program, click the folder icon or go to FILE >> OPEN and browse your PC for the FileIOSurrogate.exe usually found at C:\Program Files (x86)\Sony\Vegas Pro 9.0\FileIOSurrogate.exe

IMPORTANT: Make a backup of your original exe because you will need to swap it back into your Vegas folder whenever you apply updates.

3) Click on "File Header" at the left, look at the list at the right and click the "Click here" blue button.

4) Tick "App can handle >2GB address space"

5) "Ok" that and save by clicking the disk icon or going to FILE >> SAVE. Overwrite the file when it asks you to.

Note: You need to modify the exe file that you play your game off of - meaning TS3SP01.exe for HELS, TS3EP01.exe for WA, etc.


FOR 32-BIT OS USERS:

Try this only if you have AT LEAST 2 GByte of RAM and at your own risk.

- First download the explorer from http://www.ntcore.com/exsuite.php

- Next make a copy of FileIOSurrogate.exe found in "C:\Program Files\Sony\Vegas Pro 9.0\FileIOSurrogate". Then start "CFF Explorer" and open the original FileIOSurrogate.exe file.
- Now go to "NT Header/File Header" and click "File Header". There you will find a button labeled "click here". Click it. And select the checkbox "App can handle> 2GB address space"
- Now press the "ok"'s and when back on the main menu, click on the disk button thing (looks like Microsoft Word's "Save" button) and save the modified ".exe" file, overwrite the orginal one. (Note in Vista and 7 you must be running CFF Explorer in Administrator Mode).

- Now we need to make Windows Vista or 7 (32-Bit) ready to support more than 2 GB's (see below for XP option)
- Open command prompt with Administration rights. You find it under "Programs->Accessories->Command prompt", right click and select "run as administrator".
- Enter "bcdedit /set IncreaseUserVA 3072" (without quotes) in the command window and press enter.
After that RESTART windows

- For WINDOWS XP, don't go to command prompt. Go to "C:\boot.ini" and see where there is:
"[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect"
-TO THE END OF THE LINE (after "fastdetect"), add " /maxmem=3072" (with the space in the front, I didn't make a mistake). Also, depending on your OS, it could say "\WINDOWS="Microsoft Windows XP Home Edition" " or something (just being anal about this so that you don't ask later hehehe)

CRITICALLY IMPORTANT: The 32-bit OS method could make your system unsafe if you manage to screw up, or the information I gathered on this was screwed up (as in your computer may not boot!). So, do at your own risk please. The 64-bit OS method always works (I did it myself a few times over again to make sure), but I've never tried the 32-bit OS method before since I don't have a computer with a 32-bit OS.


I think Sony Vegas for me is working now, but I'll have to see about that later if there's yet ANOTHER bug.

Apologies for such a long post, but I hope it was helpful.


Return to posts index
Reply   Like  

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook


FORUMSTUTORIALSFEATURESVIDEOSPODCASTSEVENTSSERVICESNEWSLETTERNEWSBLOGS

Creative COW LinkedIn Group Creative COW Facebook Page Creative COW on Twitter
© 2014 CreativeCOW.net All rights are reserved. - Privacy Policy

[Top]