Creative COW SIGN IN :: SPONSORS :: ADVERTISING :: ABOUT US :: CONTACT US :: FAQ
Creative COW's LinkedIn GroupCreative COW's Facebook PageCreative COW on TwitterCreative COW's Google+ PageCreative COW on YouTube
ADOBE AFTER EFFECTS:HomeForumBasicsExpressionsTutorialsPodcastsAE TechniquesCreative Cloud DebateFAQ

Timewarp Effect Will Not Play in Realtime

COW Forums : Stop-Motion Animation

VIEW ALL   •   PRINT
Share on Facebook
Jesse HarrisTimewarp Effect Will Not Play in Realtime
by on Nov 9, 2010 at 4:38:05 pm

Hi All,

I have a foootage comp within my main composition and need to smooth out some frame skips/jumps, missing frames due to stopping the camera. I'm using Timewarp for the first time to try to solve the problem of missing frames and smooth the footage. It's a raw sequence time lapse.

I open the layer in the Preview window, double-click on the effect and try some settings. I then click RAM preview in the Preview pane and the 39 frame comp renders with a green line, takes a little more than 10 minutes. When done it starts to loop, but will never play at 30fps! I'm having a VERY hard time seeing what my settings in Timewarp are doing, if anything.

Do I need to render it out to see the effect? I've tried making a proxy of the comp, then applying the effect, and all that did was to somehow lose the cloning paint strokes I'd painstakingly done for dust on the sensor... Still wouldn't playback in realtime.

I have a fairly robust system; Mac Pro 2.66mhz, 16 gigs of ram, ATI 4870 video card, OS 10.6.4 and AE 10.0.1. Multi-processing is checked, 3 gigs ram for other apps, 1 cpu for other apps - giving me .75 gb of ram allocation per bacground cpu's.

Any tips and methods would be greatly appreciated. Thanks very much!

Or if anyone has other ideas about how to create frames in between the jumps I'm listening!!


Return to posts index
Reply   Like  

Dave LaRondeRe: Timewarp Effect Will Not Play in Realtime
by on Nov 9, 2010 at 5:20:56 pm

You may have a pretty good system, but you still can't play ANYTHING in AE. The application just doesn't work that way; it's not like an editing application, where you just hit the space bar and go.

If you're currently hitting the play button or the space bar, you're doing what's call a standard preview. AE generates a faster playback through the process of RAM Previewing. Here's the straight skinny or previewing:
http://help.adobe.com/en_US/aftereffects/cs/using/WS3878526689cb91655866c11...

It also sounds like you're pretty darned new to the application. Don't try to learn it just by messing with it; AE isn't very intuitive. It's one of those "learn to walk before you run" applications. Fortunately, Adobe's own Todd Kopriva has compiled a lot of things -- freebies, mind you -- that can help you learn to walk:

http://blogs.adobe.com/toddkopriva/2010/01/getting-started-with-after-eff.h...
Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index
Reply   Like  

Jesse HarrisRe: Timewarp Effect Will Not Play in Realtime
by on Nov 10, 2010 at 5:13:44 am

Dave,

Thanks very much for your reply. It's true I am a novice at creating in AE, however sometimes being thrown into the water is the best way to learn to swim, (with some flotation devices, namely, this forum along with Todd's) -and that's where I am in the process, swimming, not walking...

I believe I stated I was clicking the RAM Preview arrow in the Preview window, and not pressing the spacebar or the Play button. I have re-read the RAM Preview and am able to render a movie which I will post to Vimeo so you can review it if you have time.

http://vimeo.com/16676266



Thanks for taking an interest in my problems! Please let me know how I can more clearly describe my issues.


Return to posts index
Reply   Like  


Chris WrightRe: Timewarp Effect Will Not Play in Realtime
by on Nov 9, 2010 at 6:46:12 pm

I'd recommend a RAM preview, read the help for more information about this. audio off, a lower resolution, or smaller view of interest in a RAM preview helps give you longer playback, not to mention lotta ram.


this is the matrix technique for creating missing frames. They used interpolation software. This technique works for jumpy pans, tilts, dollies, spins, rotations... and of course stop motion. Here's a more detailed post.

1.Put 29.97i video in new 59.94 "start" comp so that timewarp can access both fields.

2. add effect->time->timewarp speed at 50%, extreme detail on.vector 100 if needed.

3. make new "output" comp 99 fps and drop "start" comp inside it with timestretch 50%

4. output "output" comp with original fps. It will maintain the same fps but will smooth out any jerky movements or missing frames.

http://technicolorsoftware.hostzi.com/


Return to posts index
Reply   Like  

Jesse HarrisRe: Timewarp Effect Will Not Play in Realtime
by on Nov 9, 2010 at 11:26:59 pm

Chris,

Thanks so much for this precise guidance! I've seen this technique, but with my inexperience wasn't quite positive it applied to my situation - I think it's great fix. I do have a couple of questions however.

The "output" comp is rendering as I write this, so I don't have feedback as far as a result - well now I do... Most of the footage was not displayed. There were only black frames after the first few frames... I must've screwed up your instructions, although I thought I did it correctly...

I have a fairly complicated project, as you can hopefully see from the screen shot.




I hope to be able to figure out where I went wrong with your instructions, but I have a follow-up question; most of the jumps occur between the footage layers, (I stopped the camera to adjust for exposure change, namely the sun rising!), and therefore would I have to pre-comp/flatten the entire composition to effectively use the Matrix technique? The footage I'm experimenting with happens to have jumps/skips in the middle, (where I had to cut the camera)

I hope this isn't too complicated, and I've expressed myself clearly. Thanks again for taking the time to invest in my issues! And please don't hesitate to let me know if I can clarify anything!!

I will try to post my ram preview on vimeo so you can see what I'm up against.

Regards,


Return to posts index
Reply   Like  

Chris WrightRe: Timewarp Effect Will Not Play in Realtime
by on Nov 9, 2010 at 11:57:46 pm

Here's a project I made that is setup already.

ae cs3 aep
http://www.mediafire.com/?75ywcxmvo1am5k7

Perhaps you didn't precomp your footage. Put it all in the precomp.
Timewarp, just like twixtor, can only interpolate so much or you start getting tearing artifacts. This happens around 20%, so I set my projects for 50%. The timewarp pixel effect and it's timestretch have to equal each other.

http://technicolorsoftware.hostzi.com/


Return to posts index
Reply   Like  

VIEW ALL   •   PRINT
Share on Facebook


FORUMSTUTORIALSFEATURESVIDEOSPODCASTSEVENTSSERVICESNEWSLETTERNEWSBLOGS

Creative COW LinkedIn Group Creative COW Facebook Page Creative COW on Twitter
© 2014 CreativeCOW.net All rights are reserved. - Privacy Policy

[Top]