Creative COW SIGN IN :: SPONSORS :: ADVERTISING :: ABOUT US :: CONTACT US :: FAQ
Creative COW's LinkedIn GroupCreative COW's Facebook PageCreative COW on TwitterCreative COW's Google+ PageCreative COW on YouTube
MAXON CINEMA 4D:Cinema 4D ForumCinema 4D TutorialsCinema 4D TagAdobe After Effects Forum

alpha fringe

COW Forums : Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook
ronaldoalpha fringe
by on Sep 17, 2006 at 7:04:41 am

i've been putting 2D cutouts from photoshop onto 2d planes in C4D by saving the photoshop file as a single layer with no background, loading the pshop file into the C4D color channel and then the same pshop file into the alpha channel. it works but always leaves a bit of fringe on the edges. to get around this i've resorted to going back into pshop, making a select of the art and and contracting by 1 or 2 pixels and saving this as a black/white matte that i then use in the alpha of C4D. it get's rid of the fringe nicely but involves making the second piece of matte artwork which is slightly smaller than the fill. am i missing something in C4D's alpha settings? it's a common thing to do i'm sure, but wondering does anyone have a better or more correct way to do this kind of alpha cutout without fringe?


Return to posts index
Reply   Like  

tcastudiosRe: alpha fringe
by on Sep 17, 2006 at 4:45:40 pm

Try change form SAT or MAP to "none" in the material settings.
It usually works fine (if the PS picture is hi-res enought that is).

Cheers
Lennart


Return to posts index
Reply   Like  

ronaldoRe: alpha fringe
by on Sep 28, 2006 at 8:31:46 pm

MIP-or SAT doesn't seem to have any effect on alpha edging, only on the sharpness of the actual image content.

the path i finally worked out to get a perfectly clean edge was to prep the photoshop art with no background AND create a separate alpha channel in the same pshop document. (seems redundant but it works). load the same pshop file into the color and the alpha channel of the C4d material shader. in the "Alpha" pane deselect the default "soft" setting and select "image alpha", keep color & delta as black/white and select invert (depending on how you made your pshop channel). then select the "Texture" button (where the name of the loaded material is) and then "Layerset Select" in the shader properties area. (this was what was screwing me up. you're now 3 menus down in the alpha shader menu). in this Layerset pane hilite the "Alpha Channels" button instead of "Layers/Layer Sets" and also make sure you hilite the alpha layer pic that appears below the 4 buttons. (the type descriptor will turn red). even though you selected the "alpha channels" button, if you don't hilite your alpha image below it, it won't work properly.

it seemed hidden and slightly counter-intuitive but it worked for me, really seamless edges on photoshop alpha elements.



Return to posts index
Reply   Like  

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Share on Facebook


FORUMSTUTORIALSFEATURESVIDEOSPODCASTSEVENTSSERVICESNEWSLETTERNEWSBLOGS

Creative COW LinkedIn Group Creative COW Facebook Page Creative COW on Twitter
© 2014 CreativeCOW.net All rights are reserved. - Privacy Policy

[Top]